View Issue Details

IDProjectCategoryView StatusLast Update
0006084Multi Theft Auto : San AndreasWeaponspublic2012-06-22 05:55
ReporterccwAssigned Toccw 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.0.5 
Target Version1.3.1Fixed in Version 
Summary0006084: Shot origin and target can be incorrect on remote clients
Description

Current way of calculating the shot origin and shot target is prone to errors because of the interpolation method ( CClientPed::Interpolate() ) and other reasons.

Additional Information

I suggest that some sort of weapon shot sync be added by reading the origin/target data for the local player using HOOK_CWeapon__Fire, and then writing that data with the same routine on the remote client.

TagsNo tags attached.

Relationships

related to 0004503 resolvedCazomino05 Glitch for shooting bullets remotely while reloading 
related to 0005962 resolvedCazomino05 Sawnoff shotgun glitch 
related to 0006001 resolvedCazomino05 Inaccurate shooting sync 
related to 0005373 resolvedccw peds' bullets origin from wrong position 

Activities

DivX

2011-12-28 15:54

reporter   ~~0015553

Last edited: 2011-12-28 15:54

fix it, this issue made mta some times worst than samp.

arranTuna

2011-12-28 16:01

manager   ~~0015554

Wasn't this also fixed with weapon stats changes?

Rhbk

2012-01-20 15:39

viewer   ~~0015768

Why it's was moved again? This bug shouldn't occur in Developer Preview 1! This spoil the whole synchronization of weapons, mainly such as Desert Eagle, Shotgun, Sniper Rifle. Fix this bug as soon as possible, it's a critical bug in weapons sync!

ccw

2012-02-28 07:19

administrator   ~~0016169

Last edited: 2012-02-28 07:23

r3879 has some test code for bullet sync.

The following has to be done to enable bullet sync on each client:

e.g. Enable for desert eagle:
setDevelopmentMode("bullet-sync,desert_eagle,1")

Valid weapon names are here:
http://wiki.multitheftauto.com/wiki/Template:Weapon_Types

Also, to help testing, a star appears on the nametag of remote players when they are using bullet sync for their current weapon.

ccw

2012-02-28 18:23

administrator   ~~0016175

Reminder sent to: Rhbk

Please test

arranTuna

2012-04-25 13:18

manager   ~~0016536

Last edited: 2012-04-25 13:21

Since nobody seems to have tested this for you I enabled it in bank robbery so thats 200 people in a gun battle.

performancebrowser: (I assume its packet ID 97)

97 100 2.10 KB 0.00% 13358 333.65 KB n/a

The only feedback I got was:

(support) ~|S|~Firemafia[LT]: The script causes healthbug,and shows people shooting when they are not
(support) Speed: Yea +1 firemafia

After turning it off some still have the * and appear to be constantly shooting without reloading.

ccw

2012-05-30 04:41

administrator   ~~0016723

r4178 has some test code for bullet sync and cbug firing.

The following has to be done to enable bullet sync on each client:

e.g. Enable for desert eagle:
setDevelopmentMode("bullet-sync,desert_eagle,1")

Valid weapon names are here:
http://wiki.multitheftauto.com/wiki/Template:Weapon_Types [^]

Also, to help testing, a star appears on the nametag of remote players when they are using bullet sync for their current weapon.

Make sure all testing clients are at least r4178.
(Server does not need to be updated, but should be a least r3879)

ccw

2012-05-30 04:43

administrator   ~~0016724

Reminder sent to: DivX

Please test cbug firing

ccw

2012-06-08 08:36

administrator   ~~0016772

r4219 has some test code for bullet sync and cbug firing.

The following has to be done to enable bullet sync on THE SERVER ONLY

e.g. Enable for desert eagle:
setDevelopmentMode("bullet-sync,desert_eagle,1")

Valid weapon names are here:
http://wiki.multitheftauto.com/wiki/Template:Weapon_Types [^] [^]

Also, to help testing, a star appears on the nametag of remote players when they are using bullet sync for their current weapon.

*Make sure the server and all testing clients are at least r4219.

arranTuna

2012-06-14 13:15

manager   ~~0016816

He's waiting for somebody to test it, how do you know it even needs fixing if you haven't tested it..?

DivX

2012-06-16 13:36

reporter   ~~0016820

Last edited: 2012-06-16 13:36

Now with this setDevelopmentMode is perfect but sometimes when u shot and very fast scroll to another weapon other players didnt see shoot.

ccw

2012-06-22 05:50

administrator   ~~0016872

Bullet sync should work as of r4311.

How to enable bullet sync: http://wiki.multitheftauto.com/wiki/Server_mtaserver.conf#bullet_sync

Note: The sniper does not use bullet sync. That'll have to wait for weapon creation branch to get done (1.4)

Issue History

Date Modified Username Field Change