View Issue Details

IDProjectCategoryView StatusLast Update
0006077Multi Theft Auto : San AndreasGUI / Menus / Consolepublic2011-08-27 17:23
ReporterjhxpAssigned Toccw 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformOSWindows 7 x64OS VersionSP1
Product Version 
Target Version1.1.1Fixed in Version1.1.1 
Summary0006077: Crash while changing GUI skin in Settings
Description

As above. It might happen during the first switch already.

Steps To Reproduce
  1. Start MTASA 1.1
  2. Go to Settings, then go to Interface tab.
  3. Switch between the Classic and Default skins back and forth.
  4. Boom.
Additional Information

-- Unhandled exception --

Version = 1.1-unstable-2649.0.000
Time = Mon May 09 09:17:35 2011
Module = D:\GRY\MTASA1.1\mta\cgui.dll
Code = 0xC0000005
Offset = 0x0005FAF5

EAX=00282877 EBX=15EFC598 ECX=443EBFEA EDX=44714000 ESI=0028FA70
EDI=0028FAB0 EBP=3F19999A ESP=0028FA58 EIP=0638FAF5 FLG=00010246
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

-- End of unhandled exception --

TagsNo tags attached.

Relationships

parent of 0006235 closed Source patches Patch for #0006077: Crash while changing GUI skin in Settings 
has duplicate 0005850 closed New issues Crash when changing GUI skin 
has duplicate 0006398 closed New issues MTA crashes while changing chat skin in options 

Activities

MX_Master

2011-05-09 09:55

viewer   ~~0013340

Last edited: 2011-05-09 09:56

confirmed on WinXP SP3 too.

but i saw this crash while changing to own skin

Talidan

2011-06-19 08:47

administrator   ~~0013708

Having difficulty reproducing this. May have been due to the memory corruption that impulze fixed. Please retest

arranTuna

2011-06-19 11:36

manager   ~~0013709

Changed my GUI skin from default to classic and it crashed:

Version = 1.1-unstable-2814.0.000
Time = Sun Jun 19 10:35:53 2011
Module = H:\Multi Theft Auto\MTA SA 1.1 Beta\mta\cgui.dll
Code = 0xC0000005
Offset = 0x0005F0B5

EAX=00280177 EBX=06BE92F8 ECX=44483FD4 EDX=4431FFEA ESI=0028FA68
EDI=0028FAA8 EBP=BAADF00D ESP=0028FA50 EIP=0695F0B5 FLG=00010246
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

MX_Master

2011-06-19 14:31

viewer   ~~0013716

Confirmed


Version = 1.1-unstable-2806.0.000
Time = Sun Jun 19 18:30:38 2011
Module = C:\Program Files\MTA San Andreas 1.1\mta\cgui.dll
Code = 0xC0000005
Offset = 0x0005F0D5

EAX=00220120 EBX=057032E0 ECX=44297FD4 EDX=442FBFEA ESI=0022FAA0
EDI=0022FAE0 EBP=BAADF00D ESP=0022FA88 EIP=0442F0D5 FLG=00200246
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000

Talidan

2011-06-19 15:55

administrator   ~~0013726

Strangely I'm unable to reproduce in debug mode, but it's easy in release

Cazomino05

2011-07-05 00:37

reporter   ~~0013887

Last edited: 2011-07-05 00:37

04/07/2011 23:06:41 (Error) Exception: WidgetLookFeel::getImagerySection - unknown imagery section 'normal' in look 'CGUI/ScrollablePane'.

Needs someone with a better understanding of CEGUI.

MX_Master

2011-07-05 17:14

viewer   ~~0013888

Last edited: 2011-07-05 17:52

Looks like something wrong in the skin options. I will make a patch to fix any errors in options..

Made possible fix #0006235.

diegofkda

2011-07-09 04:22

viewer   ~~0013935

Well, this is just my opinion, this would be moved to 1.1.1 goals, in 1.1.0, just make a box requesting restart the game for change the gui. anyway you won't be able to change GUI skin while playing on a server, so there won't be much difference... I don't know, I'm just saying.

Picard

2011-08-27 10:50

updater   ~~0014495

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3089 )

Issue History

Date Modified Username Field Change