View Issue Details

IDProjectCategoryView StatusLast Update
0006075Multi Theft Auto : San AndreasClientpublic2011-07-03 10:50
ReporterMaccerAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006075: dxDrawText - Add parameters of X and Y scaling
Description

There also needs to be a way for these parameters to be backwards compatible.

There's a few problems though, one of them being numbers and strings are treated the same in this function.

// CLuaFunctionDefs.Drawing.cpp, line 236
CStaticFunctionDefinitions::DrawText ( iLeft, iTop, iRight, iBottom, ulColor, szText, fScale, fScale, ulFormat, szFontName, bPostGUI, pResource );

TagsNo tags attached.

Activities

MX_Master

2011-05-09 09:53

viewer   ~~0013338

you mean dxDrawText ? i think it's not hard to do. Try first by yourself

MX_Master

2011-06-24 15:11

viewer   ~~0013777

i need this feature (: and i can make a patch.. just one question - what way of backwards compatibility i must use? I can add new args read tool (MixedRead..) which allows passing to scale argument numbers (for same x/y scale values) and tables (containing X/Y scale fields with numbers)

After adding dxCreateFont this feature becomes realy actual. Some fonts needs to be rescaled while drawing like an image, because same x/y scale for them looks not so pretty (: and i want to scale them in own style

MX_Master

2011-06-24 15:16

viewer   ~~0013778

and name of this feature request must be

> "dxDrawText - Add parameters of X and Y scaling"

not "dxDrawFont - .."

Picard

2011-06-24 21:06

updater   ~~0013781

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2832 )

MX_Master

2011-06-25 05:01

viewer   ~~0013787

thanks

Issue History

Date Modified Username Field Change