View Issue Details

IDProjectCategoryView StatusLast Update
0006072Multi Theft Auto : San AndreasGUI / Menus / Consolepublic2011-08-01 19:46
ReporterTalidanAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006072: Ensure labels cannot overlap buttons throughout the GUI
Description

This seems to depend on resolution, but key parts of GUI are being covered up as a result of text now having ordering. All areas of GUI need thorough checking to ensure that text overlapping issues don't cause major problems.

On the most part, these bugs are caused by accidently clicking text instead of the button, causing it to overlap. Places i've noticed it:

  • The close button on the server browser
  • The standard message box (e.g. connection failed)
  • Credits menu
TagsNo tags attached.

Activities

Cazomino05

2011-07-09 00:17

reporter   ~~0013932

a lot of this has changed lately, e.g. server browser and message box.
I've fixed the credits menu overlap but I can't find anything else.

arranTuna

2011-07-09 11:54

manager   ~~0013940

There is just one more thing I've noticed:

Open your favorites in the server browser and double click on gridlist so the "you need to click on a server to connect to" appears. Then click on the label and the top half of the OK button is unclickable.

Talidan

2011-07-09 14:09

administrator   ~~0013946

Ensure you have tried multiple resolutions as these bugs exist differently for different resolutions. They still exist as far as I can tell for message boxes and the server browser.

This really needs a thorough going through of all labels to ensure they cannot overlap, and that's the reason I opened this issue. The consequences of lil_Toady's changes means this bug could appear anywhere. It's frustrating that he is not willing to clean up his own mess or at least investigate it.

Do remember that this bug mostly happens if you click text first to force it in front of a button. Also, the easiest way to fix this is to use SetZOrderingEnabled(false).

Picard

2011-08-01 19:46

updater   ~~0014091

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2919 )

Issue History

Date Modified Username Field Change