View Issue Details

IDProjectCategoryView StatusLast Update
0006061Multi Theft Auto : San AndreasServerpublic2011-05-13 22:13
ReporterarranTunaAssigned Toccw 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.5-sp1Fixed in Version1.0.5-sp1 
Summary0006061: Server crash after 5 minutes of lag
Description

Server hits 120+ and about once every day we get this lag build up which goes on for about 5 minutes where everything is happening a lot later than it should and the little info bar in server console disappears (which happens when the server FPS drops very low)

MTA can't handle 120+ without it lagging up as its not the hardware resources (A lot of CPU gets used but not 100%) and not using up the connection either. Loads of players quit and then finally the lag clears up and the info bar reappears.

However this time when the info bar reappeared there was some debug spam ( http://pastebin.com/yQmQU6Pm ) then "MTAserver.exe has stopped working"

Steps To Reproduce

Get 128 people on a server, notice major resource and bandwidth consumption, may take up to a day for it to happen but there may finally be a 'lag up'

TagsNo tags attached.

Activities

Maccer

2011-05-01 07:10

viewer   ~~0013287

How much memory was MTA Server.exe using?

arranTuna

2011-05-01 11:18

manager   ~~0013288

It uses about 200mb and if itwent up we've still got about 2gb spare.

arranTuna

2011-05-07 15:33

manager   ~~0013330

Another crash but there wasn't such lag this time:

http://cit-project.net/performance/server_1.0.5-release-2637_20110507_1420.txt

Change txt to dmp

Picard

2011-05-12 02:58

updater   ~~0013368

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2663 )

Issue History

Date Modified Username Field Change