View Issue Details

IDProjectCategoryView StatusLast Update
0006059Multi Theft Auto : San AndreasClientpublic2011-06-10 22:47
ReporterarranTunaAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006059: Exported functions break if the owner resource is restarted
Description

This happens client side only.

Discovered after #6039 was fixed because I could read the debug message now.

Basically if you have a resource which has an export, and that export is called from other resources if you restart the resource with the export those resources that call it will no longer work.

So if you had a resource which drew text for various different scripts and restarted it, you would need to restart every resource that calls it for their calls to it to work again.

Steps To Reproduce

I have created two test resources which can reproduce this bug easily.

Start ResA and ResB. In the clients debug output notice a debug info message.
Restart ResB (this resource has the export)
Instead of a debug info you'll get a debug warning (because it broke)

Bad 'resource' pointer @ 'call'(1) [string "?"]

Restart ResA and the resource pointer will be updated to the new one and it will work again.

TagsNo tags attached.

Activities

Picard

2011-06-10 22:47

updater   ~~0013628

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2784 )

Issue History

Date Modified Username Field Change