View Issue Details

IDProjectCategoryView StatusLast Update
0006048Multi Theft Auto : San AndreasClientpublic2015-06-28 19:22
ReporterDevan_LTAssigned ToJusonex 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.5Fixed in Version1.5 
Summary0006048: Ped weapon isn't synced on join
Description

If you give ped a weapon before you connect to the server, the ped will be unarmed on your screen.

TagsNo tags attached.

Relationships

has duplicate 0007896 closed New issues Ped weapon dissapears after player reconnect 

Activities

ccw

2012-06-22 05:57

administrator   ~~0016873

Last edited: 2012-06-22 06:19

3) Is fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4316
4) Is fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4293

Devan_LT

2012-07-01 20:23

viewer   ~~0016938

3) Still occurs. It seems to be random, as two peds near me were shooting at me like for 20 seconds without inflicting any damage until bullets started coming out. It's probably another bug than the one which was fixed.

Devan_LT

2012-07-02 16:06

viewer   ~~0016939

I tried outputting getPedTargetEnd results in onClientPedWeaponFire. Coordinates seem to become -1.#IND on some occasions. When this happens, the bullet won't appear. Not all three coordinates necessarily become indefinite. For example, X coordinate may become -1.#IND with Y and Z remaining definite.

arranTuna

2014-09-10 13:09

manager   ~~0021986

4 issues in 1 topic was a bad idea. Since #3 and #4 are fixed and #1 is reported in another issue I'll modify this report to only be about #2.

arranTuna

2014-11-17 13:56

manager   ~~0022500

sp -712, 970, 12
srun a = createPed(1, -711, 970, 12)
srun giveWeapon(a, 25, 1, true)
Reconnect
sp -712, 970, 12
See no weapon

arranTuna

2015-06-28 19:22

manager   ~~0023471

https://github.com/multitheftauto/mtasa-blue/commit/27dd16873edbabc6663109ade2c5c9b4e3edc61e

Issue History

Date Modified Username Field Change