View Issue Details

IDProjectCategoryView StatusLast Update
0006039Multi Theft Auto : San AndreasClientpublic2011-04-27 15:15
ReporterarranTunaAssigned Toccw 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006039: Crash when restarting a resource and crashes when joining from then on
Description

In the past few days this has happened on two different occasions when editing resources (the only similarity I believe between the two occurences were the use of exported functions)

Restart resource --> crash
Join server again --> crash

Version = 1.1-unstable-2516.0.000
Time = Tue Apr 12 20:33:31 2011
Module = C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.4940_none_50916076bcb9a742\MSVCR90.dll
Code = 0xC0000005
Offset = 0x00051C72

EAX=00000043 EBX=09710697 ECX=7FFFFFFE EDX=00000073 ESI=00000000
EDI=00000043 EBP=0028E67C ESP=0028E3F8 EIP=712E1C72 FLG=00010202
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

TagsNo tags attached.

Activities

arranTuna

2011-04-12 22:32

manager   ~~0013170

Last edited: 2011-04-12 22:37

I got round all the crashes by stopping every resource then starting them one by one until the game crashed. I stopped the offending resource, all it really did was call customblips and create a bunch of customblips.

So I started customblips and then started the offending resource and it didn't crash. Restarting the server and then joining will again cause the crashes, perhaps it is to do with the ordering in mtaserver.conf? I have now tested this and confirm that it is related to the order in which resources are being started.

I don't believe this ordering has ever been a problem before, some change between 1.0.4 and 1.0.5 made resources start at slightly different times during startup because I've always got a bunch of errors (like teams not existing because the resource that creates them are started miliseconds after) when I first start the server, this change could be root cause of this crash and maybe some other problems too like those initial errors in scripts.

arranTuna

2011-04-25 11:48

manager   ~~0013224

Last edited: 2011-04-25 14:00

I am testing a script which uses an exported function to draw some dx text. Almost every time I restart it to test the changes it either crashes first time or says something like "bad resource pointer @ call k" or "bad resource pointer @ call (null) then the second time calling the export it will crash.

If the crash reporter is sending out those crash dumps there should be about 10 from me from the past few hours.

ccw

2011-04-26 23:35

administrator   ~~0013243

Possible fix in http://code.google.com/p/mtasa-blue/source/detail?r=2618

Plz test

arranTuna

2011-04-27 11:09

manager   ~~0013256

Doesn't crash now.

Issue History

Date Modified Username Field Change