View Issue Details

IDProjectCategoryView StatusLast Update
0006001Multi Theft Auto : San AndreasSynchronizationpublic2011-12-20 09:39
Reporterlil_ToadyAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.2Fixed in Version1.2 
Summary0006001: Inaccurate shooting sync
Description

When a remote player fires just one bullet out of smg/machine gun it will result in a few on your screen.
I suppose that's our key sync issue and doubt there's much we can do about that easily.

TagsNo tags attached.

Relationships

related to 0006084 resolvedccw Shot origin and target can be incorrect on remote clients 

Activities

Gamesnert

2011-03-24 16:11

developer   ~~0013104

Wouldn't it be an idea to sync individual shots instead of making the player fire through control state? If I recall correctly, laggers have a significant advantage in DM, because remote players fire much slower to him while he's firing at a at a normal rate to remote players.

Zango

2011-03-26 13:21

viewer   ~~0013114

could this be the cause of the severely inaccurate heat seeking missile?
ie. if a player locks another player in a hydra and sends off a HS missile, the missile will be somewhere completely else for the person in the hydra while he will explode randomly.

Mr.Hankey

2011-03-26 17:40

reporter   ~~0013115

Nope Zango thats a different issue. The speed of HS rockets differs when shooting either planes or cars and that speed isn't synced correctly.

PhatLooser

2011-03-28 13:14

reporter   ~~0013129

There is a difference between lag and low FPS.

CrowClaws

2011-12-20 08:59

viewer   ~~0015433

In 1.2 there's a bug with double wield weapons. Try to shoot forward running left or right, you will see the camera shaking.

W

2011-12-20 09:39

viewer   ~~0015435

CrowClaws, this isn't related to this bug, you should fill another bugreport. Besides, for me, it looks fine: http://fullserver.eu/pio/tmp/strafe.ogv

Issue History

Date Modified Username Field Change