View Issue Details

IDProjectCategoryView StatusLast Update
0005970Multi Theft Auto : San AndreasScriptingpublic2014-01-19 19:24
ReportermekoreaAssigned Toccw 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0005970: [Request] onClientVehicleDamage (server counterpart exists)
Description

^

There's no reason to have onVehicleDamage for server-side but no client-side counterpart!

http://wiki.multitheftauto.com/wiki/OnVehicleDamage

TagsNo tags attached.

Relationships

has duplicate 0006588 closed New issues onClientVehicleDamage 
related to 0006557 closed Source patches Implementation of onClientVehicleDamage 
child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Hyunsu2

2012-01-30 06:34

viewer   ~~0015902

And need 'reason' params.

Dragon

2012-01-30 10:08

reporter   ~~0015904

i guess the reason there is no such client side event is that only the damage that applies according to the syncer is accepted as actual damage by mta. therefore unless you are only interested in the vehicle damage of the vehicle you control yourself anyways, there is a reason to not have this.

arranTuna

2013-12-22 15:52

manager   ~~0019840

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=5889

Issue History

Date Modified Username Field Change