View Issue Details

IDProjectCategoryView StatusLast Update
0005955Multi Theft Auto : San AndreasScriptingpublic2011-04-16 16:40
ReporterTalidanAssigned ToTalidan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005955: Implement heuristic UTF-8 detection
Description

Currently scripts need to be marked as UTF-8 BOM to be read as unicode, but there are several disadvantages to this:

  • We require the use of an upgrader for ANSI scripts
  • UTF-8 Without BOM isn't supported
  • Since UTF-8 BOM isnt an official standard, but one used by Microsoft, many editors and systems do not properly support it.
  • UTF-8 BOM doesn't make sense and can't be properly applied to compiled scripts (#0005933).

Heuristic detection of text encoding is mostly extremely reliable, and would resolve these issues. We can still support UTF-8 BOM for convenience, but offer heuristic detection for all other scripts.

TagsNo tags attached.

Relationships

related to 0005933 resolvedTalidan Clientscript doesn't load 

Activities

Talidan

2011-04-16 16:40

administrator   ~~0013190

Fixed in r2558

Issue History

Date Modified Username Field Change