View Issue Details

IDProjectCategoryView StatusLast Update
0005933Multi Theft Auto : San AndreasClientpublic2011-04-16 16:40
ReporterTjongAssigned ToTalidan 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005933: Clientscript doesn't load
Description

Since Nightly Version mtasa-1.1-unstable-2406-20110212, client files doesn't seem to load, the debug-console outputs the following:

[2011-02-17 21:16:12] WARNING: Script '-----\client.clf' is not encoded in UTF-8. Loading as ANSI...

[2011-02-17 21:16:12] WARNING: Loading script failed: -------\client.clf: unexpected end in precompiled chunk

As you may see, it's precompiled and it does work exactly until the Version listed above.

TagsNo tags attached.

Relationships

related to 0005955 resolvedTalidan Implement heuristic UTF-8 detection 

Activities

Tjong

2011-03-25 10:00

viewer   ~~0013109

well still not fixed and is preventing me from continueing scripting in 1.1, as my scripting-system is completely based on precompiling...

is there any workaround which could fix that at least temporary?
saving the source files as UTF-8 doesn't change anything...

arranTuna

2011-03-25 16:48

manager   ~~0013110

Save the source files as ANSI.
Compile them.
Change the encoding of the compiled file from ANSI to UTF-8.

That's how we do it and it works.

Talidan

2011-04-16 16:40

administrator   ~~0013189

Fixed in r2558

Issue History

Date Modified Username Field Change