View Issue Details

IDProjectCategoryView StatusLast Update
0005902Multi Theft Auto : San AndreasScriptingpublic2014-03-12 21:16
ReporterRansomAssigned Tosbx320 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformWindowsOSWindows 7OS VersionUltimate
Product Version1.0.4 
Target Version1.4Fixed in Version1.4 
Summary0005902: Not all FX are supported by MTA
Description

This script produces some FX that are not currently supported by MTA: http://www.youtube.com/watch?v=mifR-dyFx6s ... A list of the proper missing FX names is needed and it should be relatively easy to implement them.

I do not have the list yet but I want to make sure this gets reported as requested during a discussion earlier today.

Additional Information

Currently supported FX:

  • fxAddBlood
  • fxAddBulletImpact
  • fxAddBulletSplash
  • fxAddDebris
  • fxAddFootSplash
  • fxAddGlass
  • fxAddGunshot
  • fxAddPunchImpact
  • fxAddSparks
  • fxAddTankFire
  • fxAddTyreBurst
  • fxAddWaterHydrant
  • fxAddWaterSplash
  • fxAddWood
TagsNo tags attached.

Relationships

has duplicate 0005825 closed New issues Smoke creation [Feature/Function] 
has duplicate 0005633 closed New issues Add more fx-effects 
related to 0007585 resolvedsbx320 Multi Theft Auto : San Andreas createParticle() function 

Activities

GhOsT[X]

2011-02-09 15:08

viewer   ~~0012893

http://www.gtamodding.com/index.php?title=Particle_(SA)

PhatLooser

2011-03-28 13:30

reporter   ~~0013132

Last edited: 2011-03-28 15:53

Can you do the scripters a favour and maybe replace all functions with "fxAddEffect", so there is no need for ~ 40 different functions?
fxAddEffect("wood",x,y,z,[...])
Maybe thats a bad idea, though, since the change from the DP versions to the 1.0 versions already had such a "deprecated functions" step (which I hated).

"blood_heli" bloody explosion
"boat_prop" a surf
"camflash" small flare
"carwashspray" steam, as on a carwash
"cement" cement
"cloudfast" fast clouds
"coke_puff" puff of a coke
"coke_trail" a pouring water
"cigarette_smoke" a smoke from a cigarette
"explosion_barrel" explosion and splinters of a box
"explosion_crate" explosion and splinters of the large box
"explosion_door" a smoke with sparks
"exhale" a small smoke
"explosion_fuel_car" explosion, as from the machine
"explosion_large" the large explosion
"explosion_medium" average explosion
"explosion_molotov" explosion, as from a movotov cocktail
"explosion_small" small explosion
"explosion_tiny" very small explosion
"extinguisher" foam of the fire extinguisher
"flame" small fire
"fire" fire
"fire_med" average fire
"fire_large" large fire
"flamethrower" fire of the flamethrower
"fire_bike" fire, as from a burning motorcycle
"fire_car" fire, as from the burning machine
"gunflash" as the bullet from a trunk takes off
"gunsmoke" a smoke from a gun
"insects" insects
"heli_dust" a dust, as from the helicopter
"jetpack" a jetpacks fire
"jetthrust" fire from the muffler of the machine, as during use of nitrogen
"nitro" nitro
"molotov_flame" fire from a Molotov Cocktail
"overheat_car" smoke from damaged car
"overheat_car_electric" wrecked electro-machine
"prt_boatsplash" foam
"prt_cardebris" splinters from a box
"prt_collisionsmoke" a dense white smoke
"prt_glass" a crashing glass
"prt_gunshell" shells
"prt_sand" sand, which was scattered
"prt_sand2" there is less sand, than in previous animation
"prt_smokeII_3_expand" - a grey smoke
"prt_smoke_huge" there is a lot of grey smoke
"prt_spark" of a spark
"prt_spark_2" the large sparks
"prt_splash" burst
"prt_wake" a wave
"prt_watersplash" sparks
"prt_wheeldirt" sparks from wheels of the car
"petrolcan" a jet
"puke" belch
"riot_smoke" there is a lot of smoke
"spraycan" spray
"smoke30lit" a smoke
"smoke30m" a rich smoke
"smoke50lit" more richer smoke
"shootlight" fireworks
"smoke_flare" fireworks
"tank_fire" a shot from the tank
"teargas" gas, as from gas grenade
"teargasAD" gas, as from small gas grenade
"tree_hit_fir" leaf falling
"tree_hit_palm" falling of pair large leafs
"vent" slowly dissipating a smoke
"vent2" practically too most
"water_hydrant" the large flow of water
"water_ripples" circles on water
"water_speed" the large sparks from water
"water_splash" small sparks from water
"water_splash_big" average sparks
"water_splsh_sml" sparks, only them it is not visible almost
"water_swim" small sparks at navigation
"waterfall_end" there is a lot of pair
"water_fnt_tme" the large flow of water
"water_fountain" water of a fountain
"wallbust" a disappearing heap pair
"WS_factorysmoke" smoke

Noneatme

2013-07-08 18:56

viewer   ~~0018879

1 year bumb, It would be nice to use the particles in a function

sbx320

2014-03-12 21:16

administrator   ~~0020369

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=6208

Issue History

Date Modified Username Field Change