View Issue Details

IDProjectCategoryView StatusLast Update
0005886Multi Theft Auto : San AndreasClientpublic2015-04-26 02:07
ReporterRemi-XAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowOS7OS VersionUltimate
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005886: [Editor] Objects' positions gets resetted and setted when moving the camera
Description

Well, this video should explain the problem:
http://www.youtube.com/watch?v=d-JOvmi68RQ

Steps To Reproduce

Start a map, doesn't matter if there are any other objects in it, and get some large object. Place it, leave it, and click it again. Now rotatate it, move it, use the PGUP and PGDN keys, and move the camera towards your object. This should happen.

Additional Information

Seems to occur only on larger objects. Tested it with some small objects, and they didn't resulted in this problem.

Also, this occured in my r22xx server (cant remember the exact revision), So I thought like: Let's update the resources. Didnt work, I updated the revision. Didnt work either.
It could be my PC too, since I've never had this before. But if it's not, I have atleast a bug report.

TagsNo tags attached.

Relationships

child of 0008840 closed Object sync 

Activities

Remi-X

2011-02-05 11:00

reporter   ~~0012858

Last edited: 2011-02-06 11:11

Retested this on another PC, same result. Also, I can reproduce this on smaller objects.
And, I found out that it only occurs if you move the object from a distance. If you stay closely to the object, It'll work correct.
If you are far away (like 50 units could be enough, or so), move it, then move the camera towards it, your object will be teleported. If you move it again, the objected will be teleported again, but now to the place it has to be.

EDIT: Tested this now on a MTA 1.0.4 server&client, and that worked. So it's an 1.1 bug, obviously.

DakiLLa

2011-02-09 20:25

viewer   ~~0012896

Can confirm this on 1.1 too.

XX3

2011-02-11 16:03

viewer   ~~0012905

I ever got this problem too. I say this happens on everyone.
Is this some kind of LOD problem or another bug?

arranTuna

2011-02-11 16:10

manager   ~~0012907

The reporter said that it occurs in only 1.1 and from what I see on google code the only change involving objects is this: http://code.google.com/p/mtasa-blue/source/detail?r=2312

Somebody might wana try and reproduce it in a nightly before 2312 and then one just after 2312 to confirm it is that.

Remi-X

2011-05-04 12:25

reporter   ~~0013293

Is this bug still present? Haven't tested it for a while, and I'm unable to test it myself right now. Just curious :P

arranTuna

2011-05-04 12:43

manager   ~~0013294

I tested it yesterday but was unable to reproduce, however I was unable to reproduce it in the past so you'll have to check this one for us as you know exactly how.

arranTuna

2011-05-12 15:46

manager   ~~0013384

Need Remi-X to retest this, don't forget to update 1.1 and get the newest resources.

Remi-X

2011-06-18 11:27

reporter   ~~0013702

Retested, r2806 nightly with r711 resources. Still able to reproduce.

Reproduce:
Get in the map editor, spawn a big model like 8391, the one i tested with. Place it on the ground, rotate it a bit, and copy. Move this new object aside it, rotate this one too, and move your camera. Result: it will get another position, and the rotation it has when it was copied.

This does not work on small objects; they work fine.

Picard

2011-06-28 03:44

updater   ~~0013821

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2846 )

Issue History

Date Modified Username Field Change