View Issue Details

IDProjectCategoryView StatusLast Update
0005879Multi Theft Auto : San AndreasClientpublic2013-01-05 15:50
ReporterNeO_D-PowerAssigned Toccw 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0005879: Ability to use gamepad's analog Z-axis to aim and fire a weapon
Description

Most gamepads got so-called Z-axis analog "triggers". MTA seems to use them only when driving, controlling vehicle's acceleration and brakes.
I think it would make sense to enable "triggers" on foot, to aim and fire a weapon, much like most of the controller-enabled first-person shooters (GTA IV, Call of Duty, etc.) do.
The reason I am suggesting this feature: using 2 different buttons (close to each other on 360's gamepad) to aim and fire, while rotating the camera view with right analog stick, makes it rather inconvenient, especially when you have to "walk" at the same time.

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change