View Issue Details

IDProjectCategoryView StatusLast Update
0005871Multi Theft Auto : San AndreasVehiclespublic2011-03-28 13:38
ReporterGhOsT[X]Assigned Toccw 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.5Fixed in Version1.0.5 
Summary0005871: Cars goes inside the ground when streamingout/in.
Description

Today, I've reproduced a bug that's been here for a long long time.

When a player in a car streams out and after streams in, you will see players vehicle inside the ground.

Steps To Reproduce

Open a server with CDM Mode.

Spawn as Groove, go to another team place (Police DP for example and ask a player to spawn as groove).

Then tell him to go to your location.

Additional Information

Seems that highping, make it easier to reproduce.

TagsNo tags attached.

Activities

GhOsT[X]

2011-01-27 15:12

viewer   ~~0012783

Screenshots:http://www.mediafire.com/?cfl4re06qnapuie

Remi-X

2011-01-28 09:38

reporter   ~~0012798

Able to reproduce this by spectating other players. High ping has nothing to do with it, just get a car, spectate someone else that is 100+ units away from you, and stop spectating. After that, your car will fall through the ground, and will disapear or respawn somewhere else, with or without you.

One weird sidenote: unoccupied vehicles does NOT fall through the ground.

GhOsT[X]

2011-01-28 10:12

viewer   ~~0012800

Hm, the cause that car goes in ground is that far away objects have no collision.

But mta is handling wrong when re-stream. Since the vehicle position is updating, but with a wrong Z value.

Jockie

2011-02-20 22:31

viewer   ~~0012971

It's also easy to reproduce this in a race server.

PhatLooser

2011-03-28 13:38

reporter   ~~0013133

Its possible to reproduce this in every gamemode.
If your own connection is laggy, its more likely to happen.

A fix is to make a script that sets the gravity for all occupied cars (except the one the player drives) clientside to 0.

Dunno how to solve it hardcoded. I expect that disabling the physics for far-away objects would solve that issue, but I have no way to prove it.

Issue History

Date Modified Username Field Change