View Issue Details

IDProjectCategoryView StatusLast Update
0005865Multi Theft Auto : San AndreasClientpublic2011-02-11 16:19
ReporterLooooPAssigned ToTalidan 
PrioritylowSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005865: Brazilian cruzeiro symbol isn't showed right
Description

I talk about this symbol: http://en.wikipedia.org/wiki/Brazilian_cruzeiro (Unicode U+20A2). I can write this pressing the button Alt Gr + C, but even for me, it's showed like "?" and for others peoples they don't see nothing even "?"

Additional Information

MTA:SA 1.1 r2363
MTA:SA 1.1 Server r2363

TagsNo tags attached.

Activities

Talidan

2011-01-27 11:49

administrator   ~~0012782

This is very strange, since everything else works. Copy pasting it seems to work too

Talidan

2011-01-29 09:37

administrator   ~~0012814

It seems the Windows message sent to the game is ? rather than the Cruzeiro. This is at the very lowest level, so it's something more than an MTA bug.

It may be possible to hack a fix in for any broken keys. I'll look into trying to exchange the scancodes for a unicode in special cases.

Talidan

2011-01-29 10:01

administrator   ~~0012815

Last edited: 2011-01-29 10:03

As far as i can tell, this is the same bug that prevents us from using Indic. It may be worth fixing for that too.

LooooP

2011-01-29 15:59

reporter   ~~0012820

Then shouldn't it be high priority?

Issue History

Date Modified Username Field Change