View Issue Details

IDProjectCategoryView StatusLast Update
0005843Multi Theft Auto : San AndreasSynchronizationpublic2011-03-05 00:58
ReporterRansomAssigned Toccw 
PriorityhighSeveritymajorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
PlatformOSWindows 7OS VersionUltimate
Product Version1.0.4 
Target Version1.1Fixed in Version1.1 
Summary0005843: Network trouble when playing on local server
Description

When scripting alone on your own server or with the company of others, you can experience network trouble locally.

To fix it I've found the following to work:

  1. Restart whatever script you turned on last before network trouble started
    *I have been doing utility script, no gamemode events in the script

  2. Jump
    *This only works in the network trouble that makes you immobile. Sometimes you are free to move. If so, this will not work.

  3. Respawn using freeroam

I have had this confirmed by two others who do scripting. It happens on XP and WIN7.

Steps To Reproduce

Unsure of the cause, but it appears to be scripting related. Sometimes it will happen if I join a remote server and rejoin my local server where my scripts are running. I don't even have to do anything it just pops up sometimes. It could also be related to spawning.

TagsNo tags attached.

Relationships

has duplicate 0005966 closed Cane is desync 

Activities

Remi-X

2011-01-22 23:01

reporter   ~~0012673

I've had it some times with my portalgun script, while remote users never had this. Maybe it has something to do with triggerServer/ClientEvent? since that's afaik the only part of my script what can cause this.

Jason_Gregory

2011-01-22 23:27

viewer   ~~0012675

This also happend several times on my localhost Server,
killing the playing Ped (Serverside only) solves it for me.

GhOsT[X]

2011-01-22 23:46

viewer   ~~0012676

Hm, happened sometimes with me too. IDK How to reproduce.

But a isInTrouble, should be nice to debug this.

Devan_LT

2011-01-23 00:02

viewer   ~~0012678

If I remember correctly, I've had something like that when I used pickups and peds.

Ransom

2011-01-23 00:29

administrator   ~~0012679

Last edited: 2011-01-23 04:01

!!!EDIT!!! Disregard the below message. Network trouble is not meant to happen during windowed or minimize screen focus loss of GTASA window to other windows.

======

======

Update on problem... anyone having this issue should keep in mind that:

Network trouble where you cannot move is a result of losing GTASA focus through minimize or clicking off GTASA in windowed mode. This is a nuisance to scripters to constantly come back to network trouble, but it is necessary? It will go away if you jump when you come back or wait several seconds. Fix #2 and its note are NOT RELATED.

Thus, I believe only the network trouble that allows you to move around is related to this issue. This kind of network trouble doesn't go away after several seconds in my experience without user intervention.

ccw

2011-01-23 01:07

administrator   ~~0012680

As much as I try, I can't get any network trouble at all. Some steps to reproduce this issue would be greatly appreciated.

Ransom

2011-01-23 16:51

administrator   ~~0012702

ccw has reproduced this using my scripts. It is related to bad anti-cheat code. Hotfix might be released for 1.0.4 server.

ccw

2011-01-23 18:12

administrator   ~~0012703

Test fix is in the latest nightly (from build 2355)

Ransom

2011-02-08 10:11

administrator   ~~0012884

This appears to be resolved. Someone else confirm.

ccw

2011-03-05 00:58

administrator   ~~0013023

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2355

Issue History

Date Modified Username Field Change