View Issue Details

IDProjectCategoryView StatusLast Update
0005835Multi Theft Auto : San AndreasScriptingpublic2011-07-07 14:10
ReporterRansomAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindows 7OS VersionUltimate
Product Version1.0.4 
Target Version1.1Fixed in Version1.1 
Summary0005835: Not possible to simulate satchel detonation
Description

MTA hooks into the satchel detonation process and setControlState looks at GTA functions (according to Talidan).

Steps To Reproduce

Give yourself some satchels and throw 1 then hold mouse1 & mouse2 to activate the following:

addEventHandler ( "onClientPreRender", root, function ()
slot = getPedWeaponSlot ( localPlayer )
weap = getPedWeapon ( localPlayer )
--Auto detonator for laid charges when holding mouse 1 and 2
if (getKeyState ( "mouse1" ) == true) and (getKeyState ( "mouse2" ) == true) and ( slot == 8 ) and ( weap == 39 ) and ( getPedWeapon ( localPlayer, 12 ) == 40 ) and ( exploding ~= true ) then
exploding = true
setPedWeaponSlot ( localPlayer, 12 )
setTimer ( function()
trueOrFalse = setControlState ( "fire", true )
outputChatBox ( ""..tostring(trueOrFalse) )
outputChatBox ( "boom." )
setTimer ( function()
setControlState ( "fire", false )
outputChatBox ( "unpressed" )
exploding = false
end, 50, 1 )
end, 1000, 1)
end
end )

TagsNo tags attached.

Relationships

child of 0005858 resolvedCazomino05 Make resetMapInfo take away weapons 

Activities

Talidan

2011-01-22 04:51

administrator   ~~0012664

Cleanest solution is probably to export a raw Lua function for this, since MTA pretty much handles all of it. This also applies to stealth kills, but there are further complexities involved in simulating them.

Ransom

2011-01-25 02:19

administrator   ~~0012735

Asked Talidan about confirming this in regards to resetMapInfo()

  1. Throw satchel
  2. start runcode
  3. run resetMapInfo()
  4. crun fadeCamera(true)

Satchels are still there. Removing weapons in general needs to be considered also. See related report.

Picard

2011-07-07 14:10

updater   ~~0013902

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2857 )

Issue History

Date Modified Username Field Change