View Issue Details

IDProjectCategoryView StatusLast Update
0005793Multi Theft Auto : San AndreasScriptingpublic2011-02-14 01:19
ReporterTalidanAssigned ToTalidan 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005793: Provide a solution to migration from ANSI to Unicode
Description

Scripts that currently use ANSI's extended ASCII - which applies to non-English Latin characters (e.g. German) will have their scripts broken as a result of the encoding being incompatible with Unicode. Scripters will have to open up any files containing non-English characters by hand, and save them as Unicode files.

We should look into a way (perhaps with the upgrade mechanism) to convert these ANSI characters into Unicode.

The practicality of this is debatable, since ANSI depends on the user's Locale environment to convert it into Unicode. It would have to interpret the ANSI according to the user's locale, and change it into the appropriate Unicode character.

If no solution can be found, we'll just have to document the issue properly and ensure users reencode their files.

TagsNo tags attached.

Relationships

related to 0005765 closedTalidan New issues Unicode characters are totaly wrong 
related to 0005792 resolvedTalidan Multi Theft Auto : San Andreas Implement UTF-8 BOM support for Lua 

Activities

MX_Master

2011-01-24 19:01

viewer   ~~0012725

It's realy end-user problem. Just document it.

But if we'll write on the wiki's main page with large chars "always save your lua scripts in UTF8 format" many scripters still will ask on the forum "why my unicode chars displays as incorrect chars???".

Talidan

2011-01-25 00:30

administrator   ~~0012732

I've thought about this some more, and it should be practical to autoupgrade ANSI into UTF8 for any european language. Since these scripts all use the same ANSI codepage (afaik), it should work. We don't have to worry about localisation since langauges affected by localisation don't even work in MTASA 1.0.x.

All that needs to happen is characters in 113-255 ANSI codepage need to be changed to their appropriate character in UTF8 codepage.

But yeah, it's low priority. Scripters can fix it themselves if we dont come up with a solution.

Talidan

2011-02-14 01:19

administrator   ~~0012922

fixed in r2416

Issue History

Date Modified Username Field Change