View Issue Details

IDProjectCategoryView StatusLast Update
0005767Multi Theft Auto : San AndreasGeneralpublic2011-01-08 22:32
ReporterizstasAssigned Toizstas 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindows 7OS Version6.1.7601
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005767: Incorrect Shift key processing
Description
  1. If MTA runs in windowed mode, Shift key will processed even if MTA window doesn't active. Even now, when I typing this text, I can see this.

  2. Sometimes right Shift key processed as both right and left Shift keys.

Steps To Reproduce
  1. Run MTA in windowed mode, bind something to lshift/rshift, go to another window, press Shift key.

  2. Bind something to lshift and rshift, for example:
    bind lshift say lshift
    bind rshift say rshift
    Press right Shift key for several times. After some pressing you'll get "lshift" in chat.
    Not sure, but looks like it happens when left Shift key was pressed some time ago.

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change