View Issue Details

IDProjectCategoryView StatusLast Update
0005761Multi Theft Auto : San AndreasScriptingpublic2011-03-21 07:20
ReporterCazomino05Assigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005761: [Handling] certain properties don't work or are useless
Description

List of non-working properties:
"ABS" - has no effect in vanilla gta either
"monetary" - useless as it only influences SP stats (value of damaged property)
"headLight" - doesn't work - Get works not set
"tailLight" - doesn't seem to work* - Get works not set

TagsNo tags attached.

Relationships

child of 0003457 resolvedCazomino05 request: Complete handling function set 

Activities

Remi-X

2011-01-23 16:37

reporter   ~~0012701

You gotta update:
driveType: you already fixed that in r2343.
tailLight: My handling editor is able to retrieve the value, but not able to change it.
animGroup: Works, but is model based, like it should be.

Cazomino05

2011-01-23 20:05

reporter   ~~0012708

Updated, thanks :)

Remi-X

2011-01-30 15:37

reporter   ~~0012827

Some more, both client and serverside:

engineInertia:
Very, very unstable on a value of 0. At some moments, this will cause a LSOD. Mostly when teleporting with your vehicle, or when doing weird moves with it.

percentSubmerged:
Works with values above 0. A value of 0 gives a LSOD when hitting water, and anything below 0 will be changed to 4294967296, which seems to be the maximum. Any values above that number, will make your vehicle float again. It's like it starts again at a value of 0.
Mekorea said he tested this with values below 0 successfully in the singleplayer.

Cazomino05

2011-02-12 00:18

reporter   ~~0012913

Disabled head light's (can't see much use), tail lights (can't see much use) and monetary (useless)

Remi-X

2011-03-21 07:20

reporter   ~~0013098

Are you aware that get CenterOfMass does not work properly clientside?
table = {getVehicleHandling ( veh, "centerOfMass" )} -- Returns x,y,z, now into a table

table[1] = Weird Table value
table[2] = nil
table[3] = nil
table[1][1] = nil -- In case [1] was a table for some reason

Serverside get works correctly.

Issue History

Date Modified Username Field Change