View Issue Details

IDProjectCategoryView StatusLast Update
0005745Multi Theft Auto : San AndreasGeneralpublic2011-08-30 04:17
ReporterPhatLooserAssigned Toryden 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.4 
Target Version1.1Fixed in Version1.1 
Summary0005745: When too many objects loaded by the streaming engine, the client starts to lag
Description

When there is too many objects loaded in by the streaming engine, the client starts to fade in and fade out objects like crazy, and depending on the object count, the framerate gets lower then 1 FPS on a good computer.
Worst case: The client looks into the direction of a lot of objects, and those objects start unloading and reloading randomly.

Steps To Reproduce

Build maps in Los Santos, especially around Big Smoke's house.

TagsNo tags attached.

Activities

izstas

2011-01-04 11:28

developer   ~~0012441

How many objects? There is a limit for streamed-in objects at one time.

PhatLooser

2011-01-04 11:30

reporter   ~~0012442

I don't know, it happened in the inner city of Los Santos.
Thats pretty annoying since just adding about 100 Objects there can result in serious lag.

Dragon

2011-01-05 16:48

reporter   ~~0012453

please provide a map to reproduce this

PhatLooser

2011-02-15 15:21

reporter   ~~0012944

Didn't have much time, but since I'll use the map editor anyways soon, I'll be able to provide one.

XX3

2011-02-22 14:53

viewer   ~~0012986

Last edited: 2011-02-22 15:02

I ever mod GTA SA, so I know about this.

The GTA SA's streaming reached its limit. When it breaks, it will continually drop your FPS everytime, fading in and out objects seen everytime you move around. When this happens, I was forced to restart GTA SA or MTA SA, so it works again.

To fix this permanently, you have to use a stream fix. Every GTA SA modders use this as a tool to continue modding to beyond the GTA SA's streaming limit.
More info and solution here: http://forum.mtasa.com/viewtopic.php?f=102&t=28624&p=339302#p339302

Sadly, MTA SA doesn't support ASI files. It could be a problem for this stream fix. Is there any way around?

PhatLooser

2011-08-30 00:27

reporter   ~~0014539

Seems to be solved in 1.1

Issue History

Date Modified Username Field Change