View Issue Details

IDProjectCategoryView StatusLast Update
0005718Multi Theft Auto : San AndreasGeneralpublic2011-01-16 17:48
ReporterrydenAssigned Toryden 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005718: Reduce the game loading time
Description

The GTA:SA loading splash screen of the game (the one with a progress bar and background music) is really slow, because for every progress of the progress bar it's rendering multiple frames, which are affected by the vsync, creating an artificial delay. Also, the fade-in, fade-out and background image change animations delay it even more.
This leads that even if you have a high-end computer running a 2004 game as GTA:SA, it will take at least a few seconds to load, when it could just be a matter of miliseconds.

The idea is to disable the loading splash animation, disable it completely or reimplement it at MTA. This last option would allow higher customization, such as setting our own logo.

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change