View Issue Details

IDProjectCategoryView StatusLast Update
0005715Multi Theft Auto : San AndreasClientpublic2014-11-19 00:01
ReporterGeramyAssigned ToCazomino05 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0005715: [Request] giveWeapon for clientside peds
Description

Is it able to make giveWeapon clientside for example to give a Ped a Weapon for mission for a player. it will be easier to script a clientside Player-Mission with peds. If it will be able and done thank you!

TagsNo tags attached.

Activities

izstas

2010-12-28 12:12

developer   ~~0012373

I am not sure if it safe...

Geramy

2010-12-28 13:12

viewer   ~~0012374

it can be only for Ped's not for Player that will be a possibility

Remi-X

2010-12-28 13:19

reporter   ~~0012375

The reason why it's not clientside, is because it's worth nothing. Clientside stuff are unsynched, so giving weapons clientside will NEED to trigger the server to synch it, so it's only using more bandwidth. Or, it will not trigger the server and you will be able to kill players without having a weapon on the players screen. Now that's called buggy.

Gamesnert

2010-12-28 13:41

developer   ~~0012376

Clientside stuff are unsynched, so giving weapons clientside will NEED to trigger the server to synch it, so it's only using more bandwidth.

Why does it have to be synced? The fact client-side stuff isn't synced would exactly be the reason why you might want to use it.

Or, it will not trigger the server and you will be able to kill players without having a weapon on the players screen. Now that's called buggy.

Damage is handled by the player who is being hit, not the one who's hitting. Therefore, if the other player doesn't see your weapon, he can't be damaged by it. (unless he's too close to you, because if you'd fire, you'd appear to be performing melee attacks for the other player)


This function should just be possible on client-side peds. It shouldn't be possible to use on server-side peds because that would cause syncing issues, and it shouldn't be possible for players either for the same reason.

Geramy

2010-12-28 13:51

viewer   ~~0012377

it's what i want.

the Ped should only be clientside with a clientside weapon for a special mission what i want to script

so it isn't for serverside-peds and i shouldn't be synced

arranTuna

2013-04-18 17:50

manager   ~~0018362

We can createWeapon client side but we can't giveWeapon client side which is rather unfortunate for making client side missions.

arranTuna

2014-11-19 00:01

manager   ~~0022522

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6937

Issue History

Date Modified Username Field Change