View Issue Details

IDProjectCategoryView StatusLast Update
0005712Multi Theft Auto : San AndreasGeneralpublic2011-03-28 13:25
ReporterdjloboAssigned Toccw 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.0.4 
Target Version1.0.5Fixed in Version1.0.5 
Summary0005712: Protocol 38 Error.
Description

MTA:SA Server v1.0.4-release-1996
Multi Theft Auto v1.0.4-release-2147.1

The new nightly sudently made all the player from my server (at least the ones who confirmed that they installed it) crash from the server with something that said:
"Protocol 38 ( if this persists contact blah blah blah)"

Steps To Reproduce

Just playing.

TagsNo tags attached.

Activities

djlobo

2010-12-26 19:44

viewer   ~~0012361

something i forgot to mention, it happened to around 50 players at exactly same time. most of them (the ones who answered my question) said that it was the lastest nightly.

Gamesnert

2010-12-27 19:56

developer   ~~0012370

Protocol error 38 is related to pickups. This error will be thrown if the client can't read the pickup create packet from the server. (CPacketHandler::Packet_EntityAdd; CPacketHandler.cpp: 2448)

It might be a good idea to see if upgrading the server to the latest version helps.

ccw

2010-12-27 19:58

administrator   ~~0012371

It looks like it could happen if the pickup has some sort of errored Z value

djlobo

2010-12-28 22:26

viewer   ~~0012378

the most weird is that im using this server version for a considerable amount of time (like almost a month or even more) and i never had this problem or either my players, just after the last nightly client, i will tomorrow upgrade the server and see if this still happens.

djlobo

2010-12-28 22:55

viewer   ~~0012379

Upgraded to lastest server nightly, soon i will be able to teel if this still happen or not.

ccw

2010-12-29 12:11

administrator   ~~0012383

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2159

( Use server from http://nightly.mtasa.com/mtasa-1.0.4-rc-2159-20101229.exe )

Issue History

Date Modified Username Field Change