View Issue Details

IDProjectCategoryView StatusLast Update
0005674Multi Theft Auto : San AndreasScriptingpublic2011-03-28 13:24
ReporterPhatLooserAssigned Toccw 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformOSWin Vista, Win 7OS Version
Product Version1.0.4 
Target Version1.0.5Fixed in Version1.0.5 
Summary0005674: Creation and destruction of peds seem to crash the client
Description

The creation and destruction of peds seem to crash the client, especially in combination with other players nearby.
There were not more then 80 peds and 30 players around.

If too many peds are created close to the client, so they are streamed in, the client crashes, too.

Steps To Reproduce

It happens randomly, and I absolutely have no idea why.
No mods, skin mods etc. were added.

Having a lot of peds, explosions and stuff and touching the peds client side results in such an error.

Additional Information

Seems to happen with cars, too.

TagsNo tags attached.

Activities

ccw

2010-12-11 05:19

administrator   ~~0012242

Please try to make a script which can cause this problem

PhatLooser

2010-12-15 23:26

reporter   ~~0012281

I made a script where this problem occurs from time to time, which was running on ZombieMode and crashed quite a few clients back then.
Lets put it the other way round:
The script crashes the client, and the only thing I know it does is creating and destroying peds, and setting their rotation and animation client side for all clients at once (since thats "faster sync" then setting it server side).
My humble opinion is that there might be a problem with setting the ped rotation client side, none of the other ped scripts I saw does that.

The peds don't get spawned via spawnpoints but by shooting Collision Lines in all directions and reporting back to the server where to spawn the peds.
I'll change that for the lulz (and the testings).

PhatLooser

2010-12-16 23:43

reporter   ~~0012294

Its hard to make it really crash, the problem is, the crash is totally random.
At the first test it crashed after 10 minutes, the test running right now keeps running and running and running, and nothing seems to happen.

Anyways:
http://pastebin.com/TTa1snDM - server side
http://pastebin.com/R7mTqUbz - client side

PhatLooser

2010-12-16 23:58

reporter   ~~0012295

Last edited: 2010-12-17 00:20

Just had one (thank god):
Version 2106.0.000
Code: 0xC0000005
Offset: 0x0021A392

It happened again.
Laptop 1: Flew with a hydra over the other player, crashed and died.
Laptop 2: did nothing.
Shortly after Laptop1 died and respawned, both Laptops crashed.
Laptop 1: Code: 0xC0000005 Offset: 0021A392
Laptop 2: Code: 0xC0000005 Offset: 0021A392

And again, same error code. This time I just spawned the player, killed it, then started moving it. Both crashed shortly after that. Sent it via the "internet" again.

And again, shortly after both players died and respawned and died and respawned. And moved, of course.

Maccer

2010-12-17 01:06

viewer   ~~0012297

Last edited: 2010-12-17 01:07

I know this might render the script useless, but can you test them without animations?

Actually I should, but you might be quicker than me.

(But you get an access violation error...? Hrm. Maybe it's an overflow.)

PhatLooser

2010-12-17 01:43

reporter   ~~0012300

Last edited: 2010-12-19 17:50

Just remove the client side script.
I get that error on a Win Vista Laptop, on a Win XP Laptop, and on a Win 7 Laptop. So its not just one machine there. It just seems to happen more often if there is more players online.
I could open a public server, if you want me to.

Edit:
Well, I kept my two laptops running again, this time without client side script.
None of the both systems crashed, should I run the third laptop, too?
-Still no crash without client side script.
-About 5 minutes after I activated the client side script, the sound stopped working and it crashed. Explosions speed up the crash.
-And, after deactivating the client side script, nothing happened again.

After trying it over and over, it seems that the client side script increases the probability of crashing, adding vehicles and objects seems to do so, too, but I can't say that for sure.

ccw

2010-12-22 16:19

administrator   ~~0012344

Please try: http://nightly.mtasa.com/mtasa-1.0.4-rc-2144-20101222.exe

PhatLooser

2011-01-03 18:21

reporter   ~~0012426

Last edited: 2011-01-03 18:45

"old" client crashed trice, "new" client didn't crash once.
Installed new client on both laptops, doing a half-an-hour stresstest.
After quarter an hour still no crashes...

PhatLooser

2011-03-28 13:19

reporter   ~~0013130

Fixed in 1.0.5?

Issue History

Date Modified Username Field Change