View Issue Details

IDProjectCategoryView StatusLast Update
0005659Multi Theft Auto : San AndreasServerpublic2010-12-16 20:36
ReporteronestoneAssigned ToGamesnert 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005659: onDebugMessage crashes the server
Description

An eventhandler with onDebugMessage crashes the client without an error.
Commenting out the code will make the server run as it should.

Also a dump-file is created, but the dumpfile is empty:
http://www.abload.de/img/dump7ndu.png

Steps To Reproduce

local function onServerInfo(sMessage, nLevel, sFile, nLine)

end
addEventHandler("onDebugMessage", root, onServerInfo)

TagsNo tags attached.

Activities

x86

2010-11-28 10:50

administrator   ~~0012204

Unable to reproduce.

Gamesnert

2010-11-28 13:08

developer   ~~0012205

Unable to reproduce as well. I doubt an empty function is capable of crashing anything anyway. Are you using any specific functions in the event handler?

Does the Debug Monitor ( http://wiki.multitheftauto.com/wiki/User:Snert#Debug_monitor ) work properly for you? It uses onDebugMessage and onClientDebugMessage, but doesn't crash at all for me.

onestone

2010-11-28 14:36

viewer   ~~0012206

Found the problem:

If you have an error in another onDebugMessage the server will not output the error even if you set report-level to 3.

Gamesnert

2010-12-16 20:35

developer   ~~0012292

All crashes related to on(Client)DebugMessage should be fixed as of r2124.

Please note that any errors or other debug messages caused while on(Client)DebugMessage is being triggered, will not trigger on(Client)DebugMessage, and can only be seen in the server console or the /debugscript window.

Issue History

Date Modified Username Field Change