View Issue Details

IDProjectCategoryView StatusLast Update
0005643Multi Theft Auto : EditorMap Editorpublic2011-05-12 21:56
ReporterdragonofdarkAssigned ToarranTuna 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0005643: I can't open any map
Description
  • I start resource "editor" on my server or on local server.
  • I click on "Open".
  • I chose a map.
  • I confirm the selection with "Open".
  • Nothing come...

I recorded this problem... You can see the video here : http://www.youtube.com/watch?v=V-XuEdT2lpc

Thanks if you can resolve this problem.

TagsNo tags attached.

Activities

ccw

2010-11-14 13:41

administrator   ~~0012152

I'm guessing the permissions are not correct. Possibly the editor resources do not have 'modifyOtherObjects'.

The editor ought to check for things like that and give some sort of warning.

dragonofdark

2010-11-14 15:56

viewer   ~~0012153

No, it's not that. I put all 'modifyOtherObjects' on true but that not work.

LooooP

2010-11-14 20:43

reporter   ~~0012156

Last edited: 2010-11-14 20:53

I have the same problem, it started after MTA:SA 1.0.4 r2071 update...
I'm sure it isn't because of ModifyOtherObjects, look it:
http://img249.imageshack.us/img249/854/modifyotherobjects.png

MTA:SA 1.0.4 r2071
MTA Resources r652
MTA:SA Data r1746

Gamesnert

2010-11-15 18:36

reporter   ~~0012158

I just had someone over XFire contacting me and asked me what to do. Took some time, as I wasn't able to reproduce this problem myself, but it turned out removing "editor_dump" solved the problem for him.

dragonofdark

2010-11-15 22:08

viewer   ~~0012159

Oh ! Thanks a lot Gamesnert ! That was that. I removed the resource and now that work very good good !

LooooP

2010-11-19 21:24

reporter   ~~0012171

I reinstalled MTA:SA per complete, it worked. Maybe fixed?

dragonofdark

2010-11-20 11:44

viewer   ~~0012175

I think it's because when you reinstalled MTA, it deleted the resource or it modified to default.

MX_Master

2011-02-01 14:20

viewer   ~~0012837

have same problem few days ago, and yes, there's no problems after deleting "editor_dump" resource

may be this map can't be unloaded, but editor can't load more then 1 map at the same time

Remi-X

2011-02-13 22:18

viewer   ~~0012921

Got this problem now too. Steps to reproduce?
Not sure, but it seems to happen when editor_dump isn't correctly saved. I closed my game, and directly closed the server. So, the editor had no time to save my map properly.

arranTuna

2011-04-06 16:24

developer   ~~0013163

Next time somebody gets this problem upload their editor_dump to some where so we can try and reproduce the problem as I was unable to reproduce it by messing around with editor_dump

AcidbRain

2011-04-14 13:55

viewer   ~~0013184

Last edited: 2011-04-14 13:59

Sometimes it happens that a map is saved without 'editor_main' in its definitions list. This will cause that map to be unloadable in the editor. Removing editor_dump resource will have no effect in this case.

ex:
<map edf:definitions="race">
...

To fix this, just add 'editor_main' to the edf:definitions attribute, thus:
<map edf:definitions="editor_main,race">
...

Picard

2011-05-12 15:07

updater   ~~0013380

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-resources/source/detail?r=700 )

arranTuna

2011-05-12 15:09

developer   ~~0013381

Last edited: 2011-05-12 15:10

I was able to reproduce this by removing editor_main from the edf list.

So the problem was that editor_main was being unloaded and that is the map editor being turned off.

But if anybody gets the same problem after using the fix reopen it.

Issue History

Date Modified Username Field Change