View Issue Details

IDProjectCategoryView StatusLast Update
0005642Multi Theft Auto : San AndreasServerpublic2018-09-05 17:34
ReporterRansomAssigned Toqaisjp 
PrioritylowSeverityminorReproducibilityN/A
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0005642: Server commands give no explanation or parameters when used
Description

The help command in the server is not very useful. You get a list of commands, but using them will get no response unless you use them successfully.

Problem is, how do people even know what some commands do or what the parameters are for the more obvious ones?

An image of the help command is attached just for reference.

TagsNo tags attached.

Relationships

related to 0005640 resolvedccw Mention the help command when starting a server 
related to 0005630 closedqaisjp Help command for ingame console is outdated 
related to 0005903 closed Server message "Resource is loaded, but has errors" is not helpful 

Activities

arranTuna

2010-11-14 19:35

manager   ~~0012154

Tested all the commands and gathered some details for them:

http://pastebin.com/4GNQXZQY

Looking at the amount of commands which did nothing it definitely needs an update.

DakiLLa

2010-11-14 20:29

viewer   ~~0012155

  1. info - [Doesn't appear to do anything]

Seems to be wrong. The 'info' command helps you get details about certain resource. For example 'info missiontimer'.

Zango

2010-11-15 13:26

viewer   ~~0012157

1, 18 and 5 works fine for me.
Teamsay works, you need to be in a team to start with though.

arranTuna

2010-11-16 16:51

manager   ~~0012161

And you do know that this is server console commands, not client console commands?

teamsay doesn't work because you can not put the console element in a team.

me command showed nothing in server console or ingame so prove that it really does work.

If update does work, then what does it do? I've tried stuff like update admin but all it says "No updates available for admin"

Zango

2010-11-16 19:10

viewer   ~~0012162

auch my apologises, it is indeed retarded that client commands are listed in server 'help'

'update' checks for any newly uploaded resources. I haven't had success using this on standalone windows server but works on Linux.

ccw

2010-11-17 11:16

administrator   ~~0012163

'update' depends on <update>url</update> being set in the mtaserver.conf

arranTuna

2011-03-08 16:46

manager   ~~0013041

Updated the pastebin:

http://pastebin.com/WGqZA8ZY

ccw

2011-03-09 08:56

administrator   ~~0013050

http://pastebin.com/BC2LANEE

Ca11um

2011-06-01 20:19

reporter   ~~0013548

How about '/help <command>' for more information on the command?

qaisjp

2018-09-05 05:20

administrator   ~~0026933

Replaced by https://github.com/multitheftauto/mtasa-blue/issues/406

Issue History

Date Modified Username Field Change