View Issue Details

IDProjectCategoryView StatusLast Update
0005637Multi Theft Auto : San AndreasServerpublic2012-07-16 14:36
ReporterGamesnertAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7 (64-bit)
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0005637: Element data of the root element is not synced on join
Description

Element data of the root element which is set before the player joined, is not synced properly to the joined player.

Steps To Reproduce

Easy to reproduce in the new Editor Map Testing improvements in the Race resource:

Before disconnecting:

Gamesnert executed command: getElementData(getRootElement(),"isEditor")
Command results: true [boolean]
Executing client-side command: getElementData(getRootElement(),"isEditor")
Command results: true [boolean]

After reconnecting:

Gamesnert executed command: getElementData(getRootElement(),"isEditor")
Command results: true [boolean]
Executing client-side command: getElementData(getRootElement(),"isEditor")
Command results: false [boolean]
Additional Information

Since the race editor improvements do depend on this root element data client-side, players joining a server where the testing has been started once, will get incorrect behaviour of these improvements. The keybinds won't work, in fact, they won't even appear underneath the chatbox. The loading screen simply appears, while it shouldn't appear at all.

I can't see why the race improvements use the root element to sync data in the first place, but still, it should just work.

TagsNo tags attached.

Relationships

has duplicate 0007058 closed New issues root elementData isnt synced when player joins 

Activities

John_Michael

2012-07-01 04:39

viewer   ~~0016936

Last edited: 2012-07-01 04:40

I can confirm that this still happens in 1.4 r4349.

PhatLooser

2012-07-05 19:15

reporter   ~~0016973

I can confirm it happens on all current tested 1.3.0 versions, including the latest official release.
Testing latest RC atm.

ccw

2012-07-06 19:42

administrator   ~~0016979

John_Michael, it is fixed for me. Steps To reproduce please.

PhatLooser

2012-07-13 20:49

reporter   ~~0017051

Testing it on 3 Servers showed to me the bug seems fixed.

ccw

2012-07-13 21:35

administrator   ~~0017052

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4357

Issue History

Date Modified Username Field Change