View Issue Details

IDProjectCategoryView StatusLast Update
0005618Multi Theft Auto : San AndreasServerpublic2013-09-08 12:03
ReporterBinSlayerAssigned ToCazomino05 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS VersionWindows 7
Product Version 
Target Version1.3.4Fixed in Version1.3.4 
Summary0005618: Heli Rotors are not in ghostmode in race
Description

You can still hit others even if ghostmode is enabled in 'race' with your rotors if you have a chopper/heli/rc heli. The chopper itself is in ghostmode but not the rotors

Steps To Reproduce

Play some race map with helis and turn ghostmode on and try to ram another player

TagsNo tags attached.

Activities

BinSlayer

2013-07-11 23:16

viewer   ~~0018902

Hey :) Old issue is old, but it still happens on the latest MTA 1.3.3..
Would anyone look into it as it's pretty annoying? The issue is still as described and has not changed its behaviour. Two choppers can ram each other to death even if they're both ghosted. That's because the rotors aren't ghosted.

Couldn't anyone make the rotors ghost too? :)

BinSlayer

2013-09-08 12:03

viewer   ~~0019294

I see there now exists setHeliBladeCollisionsEnabled(element, bool)
but Race ghostmode in override_client.lua uses "setElementCollidableWith" at line 60.
With this new function, you can't choose whom to make it collidable with, just to turn on/off collisions for everything related.

However, you'd need to turn heli blades collisions on/off only for selective element and "collidableWith" element, otherwise it's just weird isn't it?

Please let me know if I've got it wrong.

Issue History

Date Modified Username Field Change