View Issue Details

IDProjectCategoryView StatusLast Update
0005616Multi Theft Auto : San AndreasClientpublic2011-03-04 23:38
ReporterJohnlineAssigned To 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005616: can has gui improvements?
Description

i'd like to jump at any chance of superior coders improving elements of the current gui and the layout of some of the windows before 1.1 goes live.
i have made and been using my own modified 'square' gui for some time now, and myself and others i have given it to seem to prefer it.

maybe it could be put down to a vote, or mta could have a skin selection feature in the settings menu.
here is my proposal:
http://uppix.net/f/3/d/4191b1d8de7e26b4cbf71614b7523.png

my gui is attached \/

TagsNo tags attached.

Relationships

child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Gamesnert

2010-10-25 21:05

developer   ~~0012071

A few notes / questions: (to anyone, actually)

  • The "useless" name column in the player list is, sadly, required. A gridlist needs a column, otherwise it can't show any text at all
  • Why do you want to move the connect / refresh buttons to the bottom? They'd clearly be less visible, and the only thing which might gain from it, would be the playerlist.
  • For the lower scroll bar: Would it be an idea to resize the server browser according to the player's resolution, and storing the player's custom resizing of the browser? Would most certainly be useful to let people decide how much space they want the browser to take in, right?
  • No, "map" shouldn't removed from "Map editor." A lot of new people don't have a clue what kind of editor it would be, and might even presume it's like the GTA IV video editor.
  • Changing the theme to squared... Could that, by any chance, make older GUIs incompatible and/or plain ugly?
  • Keyboard navigation in the main menu, would that really be that much faster?

Furthermore I agree with most stuff, and the dropdown in quick connect sounds particularly interesting to me. I kind of have a lot of servers which I just switch around, and currently I use the F8 console for that. But well, that gets kinda messy, and the "favorites" tab in the server browser doesn't really make it that much better either. I might try implementing some of these sometime soon.

Johnline

2010-10-25 21:23

viewer   ~~0012072

Last edited: 2010-10-25 21:24

thanks gamesnert, you made some good points, i have some answers:

  • the 'Name' column could be changed to 'Players/Player List', and remove the title from above the box.
  • i did want more realestate for the playerlist, they're about to get long with 250 players :p, moreover i dont think it would become invisible, its logical to work your way down a panel; server parameters > selecting server > clicking connect. most people double click the list to connect.
  • storing cellspacing/windowsize would be great, currently it does none of that. it still remains that cegui has a weird bug where it displays the horizontal scroller even when all the cell headers are un-truncated. it seems truncated content of any kind triggers it.
  • wasn't sure on removing 'Map' either, so i put a '?' on it. just figured since the resource is called editor.
  • i've tested my square theme for a while now on many servers, have had no issues with it displaying the many dodgy panels people make. its a 1:1 of the existing cgui.png with adjustments.
  • i like keyboard navigation, but yeah its ambitious.

mekorea

2010-10-26 09:21

developer   ~~0012073

Seriously? Why the hell would you replace the magnifying glass with those ugly binoculars? (and please dont tell me its because you hate macs)

ARE.. http://img594.imageshack.us/img594/8260/32es.jpg

Johnline

2010-10-26 20:09

viewer   ~~0012075

Last edited: 2010-10-27 22:04

i hate macs

the binoculars are a separate png, so optional, but its not like the magnifying glass was nice either.

maybe do away with the icon, and have the searchbox have the word 'Search' in it until clicked/edited

arranTuna

2010-12-17 10:56

manager   ~~0012301

I really like the sharp edges, especially good for when the GUIs are being designed.

I carried out a poll in my community showing screenshots of both and which they prefered:

5 votes for the current (curved edges)
16 votes for the proposed (sharp edges)

There could/should be a vote on the MTA forum because I think that the sharp edges are generally prefered by people and the change should be made if the majority of votes are for the proposed style.

LooooP

2010-12-17 11:03

reporter   ~~0012302

This gui is okay, but I think there should be a way to change between the original gui and Johnline's gui, without modifying the files in MTA. Like is already did with Chats (you can click in the list and select the wanted chat on MTA)

onestone

2010-12-17 11:09

viewer   ~~0012303

@LooooP I think server-owners should have the ability to change the gui :\

LooooP

2010-12-17 16:40

reporter   ~~0012310

@onestone: I don't think because the end word is of the user

eAi

2011-01-05 16:36

administrator   ~~0012451

I like the square skin myself, but I'd like to see a GUI skin chooser in the options.

Issue History

Date Modified Username Field Change