View Issue Details

IDProjectCategoryView StatusLast Update
0005612Multi Theft Auto : San AndreasClientpublic2011-04-05 13:12
ReporterRemi-XAssigned Toccw 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOS7OS VersionUltimate
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005612: guiStaticImageLoadImage causes crash.
Description

I've seen another report elsewhere, but that was really long agao and it's still not fixed. It does work, but for some reason I got a crash after using it.

I don't know what the reason can be, but maybe the bug is just that if you try to use this function by using the same image it was before using it. That's what I'm thinking, because this problem doesn't happen when using it once.

Steps To Reproduce

What I got in my script is this function that's called every second. Most of them will just keep the same image.

Additional Information

Crash Dump:

Version = 1.0.4-release-2035.2.010
Time = Thu Oct 21 19:48:56 2010
Module =
Code = 0xC0000005
Offset = 0x53FF8B90

EAX=63ED80B4 EBX=00000000 ECX=21415AE8 EDX=53FF8B90 ESI=06A6BC00
EDI=00000000 EBP=0022FAD4 ESP=0022FAC4 EIP=53FF8B90 FLG=00010202
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000

TagsNo tags attached.

Relationships

related to 0005421 resolvedccw guiStaticImageLoadImage prone to crash? 

Activities

MaddDogg14

2010-11-01 22:26

viewer   ~~0012097

This function is definitely bugged.
Here my report from some month ago:
http://bugs.mtasa.com/view.php?id=5421

The weird thing is that is only happens to some people. I for example never had a crash because of this, while friends of mine crash every time when this function is called in some rare cases.

ccw

2010-11-19 17:32

administrator   ~~0012170

Possibly fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2078

Issue History

Date Modified Username Field Change