View Issue Details

IDProjectCategoryView StatusLast Update
0005546Multi Theft Auto : San AndreasClientpublic2013-11-12 11:33
ReporterDragonAssigned Toccw 
PriorityhighSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformQ9450 | GTX 280 | 2 GB DDR3 RAMOSWindows XP Home EditionOS Version2002 SP 3
Product Version1.3.3 
Target Version1.3.5Fixed in Version1.3.5 
Summary0005546: Vehicle and ped Z position is sometimes out of sync
Description

Especially noticeable in race's destruction derbies. When on thin platforms remote players sometimes appear underneath this platform for you. The problem usually fixes itself after a few seconds, but its an ugly issue anyways.

Additional Information

Could be an issue for peds too, but it's untested. Lag spikes or high ping are a common reason for this issue to happen

TagsNo tags attached.

Relationships

related to 0004634 closed New issues Players falling through the floor 

Activities

arranTuna

2013-07-28 17:17

manager   ~~0018999

Last edited: 2013-08-17 12:31

View 5 revisions

I saw something similar with players recently. A player close by was stood on a roof and they appeared floating under the roof. This is a fairly common kind of desync actually.

Edit: The object was solid so it couldn't have been broken object desync. Probably not a mod they've got either. Trying to get a video showing it happen a few times.

Edit: I flew around and saw 2 occurrences of this Z pos desync and another weird case when climbing on a building and the player becoming invisible (I've been seeing a lot of invisible players too recently but that's another issue) I noticed that it only occurs on thin objects like a balcony or roof with ground below it.

Video: http://www.youtube.com/watch?v=jVvFXG1h_C0&feature=youtu.be

Edit: I saw a player with a severe case of this stood nearby above me I tried to spectate him but ended spectating somebody far away and when I spectated the right person the bug had been fixed by the camera going far away and then coming back.

Also sometimes vehicles can be seen driving under the road which I guess is also Z pos desync, maybe Z is being set slightly too low?

Edit: Got another video: http://www.youtube.com/watch?v=srUnkfH3vHk&feature=youtu.be

asturel

2013-09-13 15:32

reporter   ~~0019317

http://www.youtube.com/watch?feature=player_detailpage&v=rmnZnbWsjik#t=88

arranTuna

2013-09-13 17:24

manager   ~~0019318

And what has that got to do with this report...

asturel

2013-09-13 18:50

reporter   ~~0019320

Last edited: 2013-09-13 18:51

View 2 revisions

If you watch the video you will see the player will be in the ground too. I made a screenshot for you: http://oi40.tinypic.com/w1375w.jpg But its more clear on the video, thats why I linked that instead of a picture.

arranTuna

2013-09-29 14:28

manager   ~~0019408

After playing with the ped test fix, I went to the same place where I made the video, the one with the stairwell and they keep falling. Well that still happens. I haven't seen any other sync problems though so it might have improved a bit at least.

CWanted

2013-10-17 11:02

updater   ~~0019511

https://code.google.com/p/mtasa-blue/source/detail?r=5873

Woovie

2013-11-12 00:28

manager   ~~0019649

fixed in r5873 https://code.google.com/p/mtasa-blue/source/detail?r=5873

arranTuna

2013-11-12 11:33

manager   ~~0019650

That was only for peds and I've seen it since then.

Issue History

Date Modified Username Field Change