View Issue Details

IDProjectCategoryView StatusLast Update
0005513New issuesClientpublic2018-07-22 21:45
ReporterCa11um Assigned Tomyonlake  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Summary0005513: Marker's with a size <= 1 do not trigger any marker hit/leave events.
Description

If you createMarker and the size argument is 1 or less, when an element runs into the marker, it will not trigger onMarkerHit, the same for onMarkerLeave.

TagsNo tags attached.

Relationships

has duplicate 0007099 closed collision of serverside markers with a size smaller than 1.0 is off 
has duplicate 0009823 closedmyonlake onMarkerHit is not called for cylinders of size 1.0 

Activities

Ca11um

2010-07-27 22:12

reporter   ~~0011843

I forgot to say, I've only tested it with the "cylinder" type marker.

ccw

2010-07-30 07:12

administrator   ~~0011863

Version?

Mini-Me

2012-02-22 12:47

viewer   ~~0016139

I experience the same issue server side with version 1.3-release-3741.

client code:
addEventHandler(
"onClientMarkerHit",
createMarker(216, 1875, 12.2, "cylinder", 0.5, 255, 0, 0, 255),
function()
outputChatBox("onClientMarkerHit")
end
)

server code:
addEventHandler(
"onMarkerHit",
createMarker(217.5, 1875, 12.2, "cylinder", 0.5, 0, 255, 0, 255),
function()
outputChatBox("onMarkerHit")
end
)

The markers are on the foot of the ramp in Area 69.
If you run into the clientside marker (red), the event is correctly triggered and you see the message.
If you run into the serverside marker (green), nothing happens.
=> if you raise the serverside marker to a height of i.e. 12.7, the event will be triggered.

einheit-101

2012-03-27 15:53

reporter   ~~0016377

This bug is very, very old.

myonlake

2018-07-22 21:45

updater   ~~0026847

Able to reproduce if the marker is even a bit underground. Lift it up slightly and it will trigger properly. No change required imho.

Issue History

Date Modified Username Field Change