View Issue Details

IDProjectCategoryView StatusLast Update
0005437Multi Theft Auto : San AndreasServerpublic2010-09-19 13:16
ReporterdjloboAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005437: Several Network problems
Description

This is kinda hard to explain however:
The user is playng normaly, and sudently he gets an network problem, however we could think that this is something related to the host, wich leads to me thinking that is not is:
-Once the user gets that Network problem if he types a bunch of random keys on keyboard, it disapear.
-If he gets hit by a granade or other object/anything that makes him change the position / refresh the position , it gets to normal.
-On the server where it happens ( mini-missions ) we have a comum command that is called /kill, it kills the player, if we use it, the network problem also disapear.

The network problem apears to disapear once the player gets something that affect him directly.

This issue started happening right after the upgrade of mta 1.0.4, ( i used the client runing on same server when it was using 1.0.3 and was everything fine )

Steps To Reproduce

Just playng normaly for something like 10 minutes.

Additional Information

The server is runing under high player count ( always higher then 30/40 players, reaching even sometimes 70 ), its a tdm based server.

TagsNo tags attached.

Activities

Siyo

2010-07-12 12:12

reporter   ~~0011734

I can confirm this. It happens randomly on spawn in TDMA and goes away after 10-15 seconds. They player count on the server was only 2. It's very common and should be fixed asap.

R3mp

2010-07-20 02:01

viewer   ~~0011781

Last edited: 2010-07-21 02:46

It seems to be on-foot related, ive never had it on a server running the race gamemode nor while racing on any non-race server, but get it frequently otherwise. I can confirm it happens with only 2 players online. I really hope this can be fixed before 1.1

ccw

2010-07-21 02:31

administrator   ~~0011784

How do you know there is a network problem?

R3mp

2010-07-21 02:46

viewer   ~~0011785

the network trouble message shows and you lose all control of your character, even though the game continues working fine around you

ccw

2010-07-21 05:23

administrator   ~~0011786

Use 1866: http://nightly.multitheftauto.com/mtasa-1.0.4-rc-1866-20100721.exe

It should generate a file called mta\net-trouble.log when the problem occurs. Please let me have the file.

ccw

2010-07-22 03:24

administrator   ~~0011789

Please try 1865: http://nightly.mtasa.com/mtasa-1.0.4-rc-1865-20100722.exe

ccw

2010-07-23 06:00

administrator   ~~0011797

Please try 1875: http://nightly.mtasa.com/mtasa-1.0.4-rc-1875-20100723.exe

djlobo

2010-08-17 12:16

viewer   ~~0011979

Apears to be fixed on lastest nightlys 1.0.4 1875 or up.
( confirmed by me and remp )
I barely get any network problem now, is extremely rare to say.

Issue History

Date Modified Username Field Change