View Issue Details

IDProjectCategoryView StatusLast Update
0005424Multi Theft Auto : San AndreasServerpublic2010-11-19 21:46
ReporterKaylAssigned Toccw 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005424: [Request] Additional resource monitoring functions
Description

Would it possible to have additional resource monitoring functions in order to facilitate the tracking of faulty resources and for easier server maintenance?

For instance we could have:

  • getResourceMemoryUsage(res): Each resource being confined to a memory space (since we need to use events/exported functions to communicate between resources), I guess somewhere MTA knows the amount of objects/variables and their size allocated by each resource. Having access to this information would help tracking instable/poorly coded resources

  • getResourceAverageExecutionTime(res): In a given server frame, resources are, I guess, activated depending on the events they registered for and the commands players typed. I guess MTA might be able to keep track of how long it takes for a script to execute. Having access to this information would allow to detect sensitive resources that might be poorly optimized or keeping the hand (sql queries) too long and cause server lag.

TagsNo tags attached.

Relationships

child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Kayl

2010-09-21 09:24

developer   ~~0011991

Isn't that fixed by getPerformanceStats() and the new performance screen in webadmin?

Issue History

Date Modified Username Field Change