View Issue Details

IDProjectCategoryView StatusLast Update
0005398Multi Theft Auto : EditorMap Editorpublic2010-10-21 18:15
ReporterAlPacino22Assigned ToGamesnert 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0005398: Mouse messed up on stopping test-mode while in a vehicle
Description

I have been wondering about a bug in the map editor today. I spawned myself a car through the F1 freeroam-testing, to check a road on the map. At the end, I pressed F5 to end the test-mode while being in a vehicle. And suddently my mouse got inverted/messed up while the mapping mode.
As far as I know, I didnt have such an issue with the old map editor (1.0.3)

Also when stopping in a vehicle, it looks like the cam would be moved slowly to the point that the test-mode has been started. And doesnt spawn you directly there. (Like it should do while not in a vehicle)

Steps To Reproduce
  • Enter in a server with map editor started
  • Open a map
  • Start testing-mode (F5)
  • Open the freeroam menu, spawn a vehicle (Tested on cars and bikes, but should also work with aircrafts), and sit in/on it
  • Press F5 again to stop the testing-mode
  • Mouse should be messed up
TagsNo tags attached.

Relationships

related to 0005478 resolvedGamesnert Multi Theft Auto : Editor Slightly oversized patch for the map editor 
related to 0002949 closed Multi Theft Auto : San Andreas Map editor issues 

Activities

DakiLLa

2010-06-15 01:17

viewer   ~~0011599

Can confirm that. Looks like mouse still going somewhere after you finished testing.

AlPacino22

2010-06-23 03:23

viewer   ~~0011640

Also another issue while the testing mode.
If you get weapons through the F1 menu (Or also the admin panel), when leaving the test mode, the weapons will still be shown. And when using the mouse roll, as example to rotate the object, it does switch the weapons that you have in your hands. You can see the weapons in the middle of your screen, and also while moving backwards. (Looks like a floating weapon.)

You cant remove the weapon by simply restarting the test-mode. It will stay there.
It's only removable by rejoining/leaving the server, or restarting the editor.

Gamesnert

2010-06-23 11:16

reporter   ~~0011642

I created a patch for the weapons and repeated dieing after getting back from the test mode. It seems that it fixes the camera thing as well. (or at least I couldn't reproduce, whereas I could by running Race test mode before)

http://dl.dropbox.com/u/4504893/patches/repeateddeath.patch

To be patched on the root folder of editor_main.

Gamesnert

2010-07-17 00:21

reporter   ~~0011765

Please retest in map editor r622

Issue History

Date Modified Username Field Change