View Issue Details

IDProjectCategoryView StatusLast Update
0005391Multi Theft Auto : San AndreasGeneralpublic2010-10-25 20:30
ReporterTalidanAssigned ToFlobu 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.0.4 
Summary0005391: Secondary command binds don't function properly
Description

Secondary binds added to command binds - that is, when you add a Second/Third/Fourth bind on top of the Primary bind of a command bind does not function properly. This manifests with two issues:

1) Newly added command binds, should appear in the MTA settings menu after you hit OK. Instead they dissappear entirely after being added from the first time. This is due to the new hack whereby non-mta commands are hidden if they're not requested by a resource. It simply does not account for secondary binds.

2) When adding a secondary bind to a command that has a matching 'up' state, i.e. where a key is bound to an "up" state, and a "down" state to the same command, all commands should be replicated and rebinded. By default, the MTA Settings windows hides binds associated to the upstate, and copies them over when the corresponding down state key is changed. For clarifiaction:

DESIRED BEHAVIOUR:

    <bind key="tab" state="down" command="scoreboard" arguments="1" resource="scoreboard" /> 
    <bind key="tab" state="up" command="scoreboard" arguments="0" resource="scoreboard" /> <!--This is invisible to the settings menu, but MTA is aware of it-->

Now i add a secondary bind for scoreboard to 'joy1':

    <bind key="joy1" state="down" command="scoreboard" arguments="1" resource="scoreboard" /> 
    <bind key="joy1" state="up" command="scoreboard" arguments="0" resource="scoreboard" />

Two new binds are created as a result.

CURRENT BEHAVIOUR:

    <bind key="tab" state="down" command="scoreboard" arguments="1" resource="scoreboard" /> 
    <bind key="tab" state="up" command="scoreboard" arguments="0" resource="scoreboard" /> <!--This is invisible to the settings menu, but MTA is aware of it-->

Now i add a secondary bind for scoreboard to 'joy1':
<bind key="joy1" state="down" command="scoreboard" arguments="1" resource="scoreboard" />

Only the downstate is accounted for, meaning pressing joy1 will show the scoreboard but releasing it will not hide it.

TagsNo tags attached.

Activities

Flobu

2010-09-25 12:39

updater   ~~0012003

Does anyone notice problems with this since it is backported?

Talidan

2010-10-14 02:51

administrator   ~~0012041

I have not noticed the issue, and successfully binded keys. Can be marked as resolved according to my tests.

Issue History

Date Modified Username Field Change