View Issue Details

IDProjectCategoryView StatusLast Update
0005386Multi Theft Auto : San AndreasClientpublic2011-09-22 08:56
ReporterDragonAssigned Toccw 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformQ9450 | GTX 280 | 2 GB DDR3 RAMOSWindows XP Home EditionOS Version2002 SP 3
Product Version 
Target Version1.1.1 R2Fixed in Version1.1.1 
Summary0005386: Long vehicles controlled by remote clients sometimes shake weirdly
Description

I usually see this happen in race, it's pretty annoying for teamwork maps, because you can barely drive on them. It usually normalizes when you wait some time (20-60 seconds). Confirmed for packer and coach and probably other long vehicles

TagsNo tags attached.

Relationships

has duplicate 0005846 closed New issues Packer (Vehicle) Sync. 

Activities

[RcF]Ghost

2010-06-14 03:40

viewer   ~~0011595

yeah, i can confirm this, after sometime it stops, seems to not be related to high ping or low fps.

Happens on custom objects and default objects.

Seems to be something related to velocity or rotation and maybe related to streaming (collision) too.
And seems in someway/somehow to be related to #0005318

IDK the really steps on how to reproduce.

Maccer

2010-08-05 15:55

viewer   ~~0011909

Strangely enough, I get this on myself on some not so huge vehicles. But I think that's due to high FPS. But they shake the body in place, so it doesn't really bother me.

Remi-X

2010-12-22 17:40

reporter   ~~0012345

http://www.youtube.com/watch?v=G2qhnhOdnsw
Confirmation video. It's really bad, as you can see.

LooooP

2010-12-23 11:49

reporter   ~~0012348

http://www.youtube.com/watch?v=iLCz9SE_zWc

GhOsT[X]

2011-01-23 10:16

viewer   ~~0012689

Link:http://img818.imageshack.us/i/jlc.mp4/
DirectLink:http://img818.imageshack.us/img818/117/jlc.mp4

PhatLooser

2011-02-04 18:11

reporter   ~~0012853

Knowing the GTA engine, I'd say its the suspension.
Does MTA "freeze" the position of vehicles to the place the engine supposes them to be?

MX_Master

2011-02-04 18:49

viewer   ~~0012856

Last edited: 2011-02-04 18:50

Confirmed. Packer really has fun shakes while other players near it, but only for them, not for packer's driver.

Talidan

2011-04-23 01:46

administrator   ~~0013217

Need a way to reproduce

MX_Master

2011-04-23 18:27

viewer   ~~0013218

it was my way

  • start "freeroam"
  • create "packer" vehicle, enter it and drive around other players
  • let other players to put their vehicles over your "packer"
  • turn up the "packer"'s platform and drive around other players

tvc

2011-07-08 16:08

viewer   ~~0013924

Last edited: 2011-07-08 16:16

Confirmed on latest 1.1 nightly.

http://youtubedoubler.com/?video1=96vwlYF-lV4&start1=1&video2=XO1NRQtijyg

I (client in Packer) had around 400ms ping and the client in the car had around 30ms.

Dragon

2011-09-20 15:19

reporter   ~~0014836

2011-08-02 00:30 ccw Target Version 1.1 => 1.1.1
2011-09-19 18:45 x86 Target Version 1.1.1 => 1.1.2

zzz

Picard

2011-09-22 08:56

updater   ~~0014864

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3217 )

Issue History

Date Modified Username Field Change