View Issue Details

IDProjectCategoryView StatusLast Update
0005373Multi Theft Auto : San AndreasClientpublic2012-06-22 06:17
ReporterGrimReaperAssigned Toccw 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0005373: peds' bullets origin from wrong position
Description

when a ped shoots, the bullet's origin will be the position of the ped and not the position of its weapon's muzzle. Due to this, the ped will shoot itself from its inner body, but cannot hurt itself. But that also means that no bullet can be fired to the outside of the ped's body and therefore the target will not receive any damage. Only when the ped changes its position e.g. by getting hit by a car or knocked by a player, the bullets' orgin position will remain the same and the bullet will reach its target.

TagsNo tags attached.

Relationships

related to 0006084 resolvedccw Shot origin and target can be incorrect on remote clients 

Activities

ccw

2012-06-22 06:17

administrator   ~~0016874

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4316

(Muzzle position not used as it is unreliable if the ped is off screen)

Issue History

Date Modified Username Field Change