View Issue Details

IDProjectCategoryView StatusLast Update
0005336Multi Theft Auto : San AndreasOptionalpublic2010-05-31 11:50
ReporterPhatLooserAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005336: Create possibility to switch off the anticheat
Description

Since there is some servers where cheating is allowed, please give the server owners the possibility to switch off the anticheat.

TagsNo tags attached.

Activities

Talidan

2010-05-16 01:33

administrator   ~~0011475

Arguable - 'cheating' should be facilitated by means of script.

robhol

2010-05-16 01:35

reporter   ~~0011477

Last edited: 2010-05-16 01:37

While I have "ethical objections" against any kind of cheating, it is undeniably better that some cheaters (no, they're not likely to settle for scripted cheats) can do their thing in some place where they don't bother honest players and server admins.

Also, since the MTA anticheat has a long history of assorted malfunctions, maybe a killswitch could come in handy anyway... And if someone scripts an anticheat and wants that to "take over" without any hard-coded interference, this would be useful in yet another way.

Talidan

2010-05-16 16:55

administrator   ~~0011479

I still think that MTA shouldnt be relying on external applications to be running for any reason, especially when most of the cheats can be facilitated by script for players to use.

However, i do agree about a possible need for a killswitch, that alone may justify this addition. It shouldn't be a hard add either.

x86

2010-05-31 11:50

administrator   ~~0011524

Fixed in: http://code.google.com/p/mtasa-blue/source/detail?r=1695

Issue History

Date Modified Username Field Change