View Issue Details

IDProjectCategoryView StatusLast Update
0005331Multi Theft Auto : San AndreasServerpublic2010-05-31 17:21
ReporterGamesnertAssigned To 
PriorityhighSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005331: Anti-cheat is broken
Description

Anti-cheat in the latest nightly seems so overreactive, that it even kicks for standing somewhere idling. Standing on fast objects seems to be reason enough to kick you, and apparently several random other reasons. It makes MTA kind of unplayable.

Additional Information

Interestingly, it seems that a 1.0.3 client on a 1.0.4 untested 32 server also gets kicked. This may point to some server-side anti-cheat being a pain in the butt. We didn't test in vehicles, but on foot AC is annoying as can be.

Modes tested: CP, MTAWare and CnR (all on Dragon's server)

TagsNo tags attached.

Activities

x86

2010-05-15 19:01

administrator   ~~0011473

Last edited: 2010-05-24 13:13

It's mostly AC #2 (ammo failed), when shooting with big weapons.

Issue History

Date Modified Username Field Change