View Issue Details

IDProjectCategoryView StatusLast Update
0005318Multi Theft Auto : San AndreasServerpublic2014-09-07 21:33
Reporter[M2S]moeAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows OS Version2003 Server
Product Version 
Target Version1.3.2Fixed in Version 
Summary0005318: setElementPosition for vehicles on a non streamed in position will make the vehicle spin very quickly
Description

When you setElementPosition (client or server side) for a vehicle to a non streamed in X,Y,Z, the vehicle will spawn near (but not at) the coordinates and spin very quickly.

Steps To Reproduce

Just setElementPosition for a vehicle to any X,Y,Z not streamed in. The coordinates (Z included) do not matter, it happens everytime.

TagsNo tags attached.

Relationships

has duplicate 0005479 closed New issues Vehicles are spacing after warped on a large distance with setElementPosition. They get speed of it. 
has duplicate 0005604 closed New issues setElementPosition doesn't work properly with vehicles 
related to 0008522 closed New issues Motorbikes spin out of control when warping them to places which are streamed out 

Activities

ccw

2010-05-31 00:11

administrator   ~~0011519

Could not reproduce this. Do you have an example script?

PhatLooser

2010-05-31 00:15

reporter   ~~0011520

its pretty easy:
join a server, open the admin console, enter the line
setElementPosition(getPedOccupiedVehicle(getPlayerFromNick("your_face")),5000,5000,100);
into that command thingy and enjoy the spin.
I reproduced it that way.

Mr.Hankey

2010-07-13 17:42

reporter   ~~0011746

"Following offsets are Floats, as positions of doors and other car parts that gets detached by damage. We need to recalculate and set their locations if we warp a car from one location to another. Otherwise the car spins uncontrollably"

taken from: http://www.gtamodding.com/index.php?title=Memory_Addresses_(SA)#Cars

Cazomino05

2012-06-19 19:11

reporter   ~~0016847

Reproduced with a coach.

ccw

2012-08-15 03:32

administrator   ~~0017297

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4488

Issue History

Date Modified Username Field Change