View Issue Details

IDProjectCategoryView StatusLast Update
0005290New issuesClientpublic2013-01-18 23:14
ReporterMCvarialAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Summary0005290: toggleControl does not work for the analog inputs
Description

Using a plug 'n' play xbox controller to play mta causes bugs with the control state system: e.g. toggleControl("accelerate",false) stops you from accelerating with a keyboard but not with the controller.

Note: I don't own a xbox controller myself so I can't test.

TagsNo tags attached.

Relationships

duplicate of 0005065 resolvedCazomino05 Multi Theft Auto : San Andreas Disabling controls doesn't disable analog sticks in gamepads 
related to 0004024 resolvedJusonex Multi Theft Auto : San Andreas toggleControl isn't working for mta controls 

Activities

Talidan

2010-06-01 00:40

administrator   ~~0011529

Last edited: 2010-06-01 00:40

I do this all the time to cheat in Race. I've investigated the issue but the main problem lies int he fact that the Joystick code is trapped in between deathmatch and core, and making a clean fix is difficult.

Issue History

Date Modified Username Field Change