View Issue Details

IDProjectCategoryView StatusLast Update
0005285Multi Theft Auto : San AndreasClientpublic2014-11-17 23:07
ReporterDevan_LTAssigned ToJusonex 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0005285: Unwanted behavior of some burglary houses
Description

I noticed a strange behavior of some interiors. I'm making entrances to houses in my gamemode and noticed that burglary houses tend to crash GTA when I teleport to them. Another strange thing is disappearing furniture. In the image I uploaded you can see the difference. The top image shows how it was when I teleported first. The bottom image shows what it became when I restarted both server and client. I noticed this bug in these interiors:
x:-43 y:1406 z:1085 interior: 8
x:-69 y:1344 z:1080 interior: 6
x:-264 y:1449 z:1085 interior: 4
x:-292 y:1478 z:1090 interior: 15

TagsNo tags attached.

Activities

Devan_LT

2010-04-07 15:51

viewer   ~~0011347

Last edited: 2010-04-07 15:52

image (you may need to copy this address to address field): http://www.freewebtown.com/devann/MTA_furniture.JPG

XX3

2010-04-28 17:43

viewer   ~~0011398

Last edited: 2010-04-28 17:44

This is a minor bug, MTA needs to fix this ASAP. I don't even know why that happens.

qaisjp

2014-11-16 01:54

administrator   ~~0022401

cannot reproduce

AlexTMjugador

2014-11-16 11:17

viewer   ~~0022430

I can confirm that in 1.3.5 one burglary interior almost always crashes GTA when teleporting to it (I'm going to upload crash details if it's still an issue in 1.4). I have also seen in 1.3.5 unsynced pedestrians inside some of these house interiors which behave like in singleplayer: they lay in beds and sit in sofas. However, the chances to see them are rare.

arranTuna

2014-11-16 12:09

manager   ~~0022432

Needs some dump files at least.

qaisjp

2014-11-16 15:58

administrator   ~~0022446

"I have also seen in 1.3.5 unsynced pedestrians inside some of these house interiors which behave like in singleplayer: they lay in beds and sit in sofas. However, the chances to see them are rare." I want to see this.

AlexTMjugador

2014-11-16 18:32

viewer   ~~0022462

Confirmed crash in 1.4 when teleporting to the burglary house x = 327.94, y = 1477.73, z = 1084.44, interior = 15 from x = 223.07, y = 1287.09, z = 1082.14, interior = 1 (dimension 54 in both cases). Dump: https://mega.co.nz/#!DElXiATK!pW7aFuvH33DciwWQ5VJeGY-MlEAhRCquHRvqx7n53HQ

Another crash when teleporting to burglary house x = 260.98, y = 1284.40, z = 1080.08, interior = 4 from x = 2317.82, y = -1026.75, z = 1049.21, interior = 9 (dimension 54 in both cases): https://mega.co.nz/#!7McxxTKS!2jMplNa_wQL6ZvWIWPfh6_xZkRM-OLZhCnmdIJjHuGk

It also crashed more times when teleporting to other interiors, but I didn't upload the dumps because I think that with these two it's enough. This interior, specially, seems to be more prone to crashes: x = 387.23, y = 1471.79, z = 1080.19, interior = 15. However, I couldn't reproduce the unsynced singleplayer pedestrians issue no more, so I think it was fixed at some point.

Dutchman101

2014-11-16 20:23

updater   ~~0022471

Try with this test crashfix
https://code.google.com/p/mtasa-blue/source/detail?r=6932

StifflersMom

2014-11-16 20:43

updater   ~~0022472

I can confirm randomly crashing just by clicking the interiors from freeroam.
start freeroam, click the following interiors without moving the player:
Safe House 18
Safe House 2
(and so on)
Safe House 8 (crashes alwasy here for me)
Version = 1.4-release-6922.0.000
Time = Sun Nov 16 20:38:33 2014
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x00193C6F

EAX=0028F2E8 EBX=40000000 ECX=00000000 EDX=00000000 ESI=00BB2B7C
EDI=1F30474C EBP=00B4D82C ESP=0028F2D8 EIP=00593C6F FLG=00010206
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

If needed, I think I can provide dumps also.

qaisjp

2014-11-16 21:08

administrator   ~~0022473

I did exactly as StifflersMom said and didn't crash.

StifflersMom

2014-11-16 21:33

updater   ~~0022475

I checked it with 6922, it crashes every time. Not tested with 6932 yet.

qaisjp

2014-11-16 21:34

administrator   ~~0022476

I tested with r6918.

lopezloo

2014-11-16 22:27

developer   ~~0022477

Last edited: 2014-11-16 22:28

View 2 revisions

Can't reproduce with freeroam, also I can't reproduce while I'm teleporting between interiors using 100ms timer:
run setTimer(function() if a then spawnPlayer(getRandomPlayer(), 327.94, 1477.73, 1084.44, 0, 0, 15, 54) else spawnPlayer(getRandomPlayer(), 223.07, 1287.09, 1082.14, 0, 0, 1, 54) end a = not a end, 100, 0)

r6928

But I reproduced when I'm staying on house interior roof and I change pos clientside to lower height (to entry house).
Version = 1.4-release-6928.0.000
Time = Sun Nov 16 22:24:21 2014
Module = D:\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x00193C6F

EAX=0028F2EC EBX=40600000 ECX=00000000 EDX=00B4CF6C ESI=00BB2B7C
EDI=1D588144 EBP=00B4CF6C ESP=0028F2DC EIP=00593C6F FLG=00210206
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

qaisjp

2014-11-16 23:37

administrator   ~~0022478

"But I reproduced when I'm staying on house interior roof and I change pos clientside to lower height (to entry house)."
That is very weird. Could this have anything to do with furniture loading?

StifflersMom

2014-11-16 23:39

updater   ~~0022479

Yes. We should retest it with 6932 if available, Jusonex applied a test fix for it.

Jusonex

2014-11-16 23:43

administrator   ~~0022480

The crash occurs when GTA tries to generate a new random seed for dynamic furniture generation. For some reason (which I don't know yet) the variables GTA needs to generate this seed got invalid.

My test hackfix skips random seed generation entirely.

StifflersMom

2014-11-17 08:28

updater   ~~0022481

Checked with r6932 - For me, it doesn't crash anymore.

lopezloo

2014-11-17 18:59

developer   ~~0022506

For me too. Btw. I made video which showing how good this working now: http://youtu.be/jdT2nb9B8RQ

AlexTMjugador

2014-11-17 19:28

viewer   ~~0022508

Last edited: 2014-11-17 19:35

View 3 revisions

The issue got fixed for me too with latest nightly. It doesn't crash anymore.

However, it's me or now some of these interiors are generated with more variated furniture than before? Also, as a result of latest nightly, other interiors don't generate most furniture, at least for me (and I didn't disable them from generating using setInteriorFurnitureEnabled). Here's a screenshot: https://mega.co.nz/#!fBMzGS7Z!9vr3dvnFlj6nw0T-rQt39ueiEjIKygPOllBTQDCOzbY

Edit: the furniture seems to only stop generating for me when changing between burglary interiors. Restarting MTA, as expected, fixes that.

lopezloo

2014-11-17 20:32

developer   ~~0022509

"Also, as a result of latest nightly, other interiors don't generate most furniture, at least for me (and I didn't disable them from generating using setInteriorFurnitureEnabled)." Furniture are visible only when player is near (not camera). You must spawn player in this house too see furniture.

AlexTMjugador

2014-11-17 20:49

viewer   ~~0022510

I teleported the camera and the player inside the house and I didn't see more furniture than in the screenshot. I took the screenshot from a certain distance to see the bug more clearly only (and the freecam script that I use it's like editor's, so it also teleports the player to the camera).

Issue History

Date Modified Username Field Change