View Issue Details

IDProjectCategoryView StatusLast Update
0005283Multi Theft Auto : San AndreasScriptingpublic2010-08-09 23:39
ReporterkwksndAssigned ToGamesnert 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005283: playSound3D does not support interiors or dimensions
Description

there is no place to use arguments for interiers or dimensions in the playSound3D function, making it not usable for interiers or other dimensions.

TagsNo tags attached.

Activities

[RcF]Ghost

2010-04-06 21:14

viewer   ~~0011346

Last edited: 2010-04-06 21:22

have you tried with setElementInterior/setElementDimension? (This function allows you to set the interior of any element/This function allows you to set the dimension of any element), idk maybe works :).

Edit:
After reading on the wiki, i found that it's possible to use setElementDimension and setElementPosition.
About setElementInterior, i don't know, but since Sound is a element, it may work, but maybe someone forgot :). (Someone please update the wiki).

IMHO: playSound3D ( string soundPath, float x, float y, float z, interior, dimension, [ bool looped ] ) would be great. (but useless because it's easy to do with some redirects(stock))

Info:http://wiki.mtasa.com/wiki/Sound

x86

2010-08-09 23:39

administrator   ~~0011945

Fixed in: http://code.google.com/p/mtasa-blue/source/detail?r=1914

Issue History

Date Modified Username Field Change