View Issue Details

IDProjectCategoryView StatusLast Update
0005272Multi Theft Auto : San AndreasServerpublic2010-04-23 15:04
ReportervarezAssigned ToFlobu 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005272: [request] getTimer
Description

I'd like to see a function that will get the time of timer specified as parameter, like:

local timeToEnd = getTimer(myTimer)

Additional Information

im not sure if im posting it (request) correctly. feel free to edit, move, whatever with this report :)

TagsNo tags attached.

Relationships

child of 0003344 closed New Feature Requests Requested features tracker 

Activities

AcidbRain

2010-03-31 17:27

viewer   ~~0011298

This is most useful, also because I've come across some situations where I receive a warning when calling killTimer on an expired timer.
But if there was a way to know if a timer has expired, these warnings could be easily averted.

drifterCZ

2010-04-05 08:02

viewer   ~~0011338

add row "timer = false" into timer function and when you later call "isTimer ( timer )" it will return false :)

Flobu

2010-04-06 03:43

updater   ~~0011344

Last edited: 2010-04-06 03:46

http://github.com/Flobu/multitheftauto/commit/9a275fc79ab3aa20087d6c8d517225d1f4474705
add the function client and server side
timeleft, repeatsleft, delay = getTimer( timer )

x86

2010-04-23 09:42

administrator   ~~0011383

Fixed in: http://github.com/multitheftauto/multitheftauto/commit/e4467e1179853ca20ba717783160bf2d92a5e65f

Flobu

2010-04-23 15:04

updater   ~~0011385

Rename getTimer to getTimerDetails (mentioned by Talidan)
http://github.com/Flobu/multitheftauto/commit/55dc2120eb6ce146df10e744725373fa7ed157d7

Issue History

Date Modified Username Field Change