View Issue Details

IDProjectCategoryView StatusLast Update
0005236Multi Theft Auto : San AndreasMapspublic2015-08-07 03:16
ReporterJohnlineAssigned Toccw 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.0.3 
Target Version1.2Fixed in Version1.2 
Summary0005236: LOD system for custom models
Description

currently the mta streamer can only draw map models at 300 units from the player. Although not considered vital, this is a visual limitation that would be nice to overcome for 1.1

i've been thinking how it can be done in a smart way that won't interfere with scripting practices, and have come up with a system that could work in resources:

  • all dffs and cols are individual, unclumped models, all are defined in the meta.xml
  • the mta engine detects LOD models by naming convention; eg. if craphouse.dff is the HID model, LODphouse.dff is the LOD model. this same naming convention applies to col files.
  • the LOD and HID work off the same object ID, this way scripts remain unaffected.
  • the mta streamer swaps the HID and LOD depending on proximities set.
  • a script function for defining LOD draw distance value needs to be made, or a default value of 1500 could be assigned for all custom model LODs in the meantime.
  • mta should disregard any single player draw distance setting and work from the scripted values for custom objects.

problems to overcome with this system:

  • filenames will need to be atleast 4 characters when making the resource, but thats just common sense on the resource maker's part.
  • the mta streamer will need to transition the LOD with the HID without flickering, stalling, and probably with the same fade effect gta uses.

norby also suggested a bool for createObject, but thats really another issue

TagsNo tags attached.

Relationships

child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Johnline

2010-03-13 19:32

viewer   ~~0011156

to exemplify the limitation:
http://www.xfire.com/video/198329/

XX3

2010-04-25 17:49

viewer   ~~0011388

It could be good if you can make LOD for every objects you made too. And LOD for Custom objects only if they offer one.

TheDannyDevito

2010-09-26 13:00

viewer   ~~0012006

SetElementStreamable does not work. ;-(

http://www.youtube.com/watch?v=EunykznrEOc

ccw

2010-11-20 00:38

administrator   ~~0012174

"- mta should disregard any single player draw distance setting and work from the scripted values for custom objects."

Therein lies the rub

PhatLooser

2011-03-08 17:41

reporter   ~~0013042

interesting part is that the shadows always stay the old ones. In race, the pickups cast the shadow of a tree.

Remi-X

2011-03-08 18:55

reporter   ~~0013043

@ PhatLooser:
That's because of MTA's DFF import-thing, it apparently does not load everything. Shadows are embedded in the DFF, if I remember right. CMIIAW

ccw

2011-12-04 14:53

administrator   ~~0015330

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3513

x86

2012-03-01 16:37

administrator   ~~0016189

Still not as it should be.

ccw

2012-03-01 17:03

administrator   ~~0016190

What is the problem?

x86

2012-03-01 17:09

administrator   ~~0016191

Objects are still disappearing at short distance (using example #2 of the wiki):
http://wiki.multitheftauto.com/wiki/SetLowLODElement

ccw

2012-03-01 17:36

administrator   ~~0016193

Works fine here.
Maybe we need to manage expectations.

x86

2012-03-01 17:38

administrator   ~~0016194

It should match with the LOD distance like SA

ccw

2012-03-01 18:13

administrator   ~~0016196

Updated wiki example.
Does that help?

x86

2012-03-01 18:57

administrator   ~~0016197

Negative, still the same as before.

x86

2012-03-01 19:25

administrator   ~~0016199

I tried with some big land objects, seems to work like it should (huge LOD distance). Shouldn't be there a hack to increase the LOD distance of such small objects ? Would be very handy!

TheGTA

2013-04-01 17:44

updater   ~~0018308

If the current LOD system is not enough, wait till I implement custom RenderWare rendering into Eir.

ccw

2013-04-02 12:27

administrator   ~~0018310

It is working, although I presume it will need redoing for Eir

Issue History

Date Modified Username Field Change